EasyApache update won't run for the past few months

KelAt

Registered
Mar 15, 2013
2
0
1
cPanel Access Level
Reseller Owner
I get this error...

PHP:
If the browser window is closed or stopped the build will continue in the background.
The build output should start shortly...

!! Local template detected: /var/cpanel/templates/apache2/vhost.local !!

!! Local template detected: /var/cpanel/templates/apache2/ssl_vhost.local !!

!! 
If there are issues with your local templates you might be interested in setting the 'When there are problems with local templates and the default templates are tried, move the local one to a .broken extension.' preference. !!

Distilled successfully
Updated FD_SETSIZE in /usr/include/bits/typesizes.h to 16384
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1390559566' !!
!! 
Output from '/bin/sh -c "ulimit -a"': 
core file size          (blocks, -c) 1048576
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 257203
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1024
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 10240
cpu time               (seconds, -t) unlimited
max user processes              (-u) 257203
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited
!!
!! Creating backup of working apache in '/usr/local/apache.backup'. !!
!! Symlink encountered (/usr/local/apache/etc), preserving target (conf)... !!

!! Backup of working apache complete. !!
Checking that all tarballs are present and up to date.
!! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/Apache/2_4.pm.tar.gz' !!

!! Custom opt mod 'Cpanel::Easy::ModCloudflare' is using custom opt mod tarball '/var/cpanel/easy/apache/custom_opt_mods/Cpanel/Easy/ModCloudflare.pm.tar.gz' !!
!! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/ModSec.pm.tar.gz' !!

!! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/PHP5/4_24.pm.tar.gz' !!

!! Downloading '/var/cpanel/perl/easy/Cpanel/Easy/PHP5/4_24.pm.patch.tar.gz' !!

Checking that all packages are present and up to date.
Loaded plugins: fastestmirror
Determining fastest mirrors
Setting up Install Process
No package automake19 available.
Package gettext-0.17-16.el6.x86_64 already installed and latest version
Package 2:libpng-devel-1.2.49-1.el6_2.x86_64 already installed and latest version
Package readline-devel-6.0-4.el6.x86_64 already installed and latest version
No package libpng-dev available.
No package autoconf261 available.
Package libidn-devel-1.18-2.el6.x86_64 already installed and latest version
No package gmake available.
Package libidn-1.18-2.el6.x86_64 already installed and latest version
Package patch-2.6-6.el6.x86_64 already installed and latest version
No package libltdl3-devel available.
No package libltdl available.
No package libopenssl0.9.7-static-devel available.
No package readline-dev available.
Package libtool-ltdl-devel-2.2.6-15.5.el6.x86_64 already installed and latest version
Package sed-4.2.1-10.el6.x86_64 already installed and latest version
No package libXpm-dev available.
Package lsof-4.82-4.el6.x86_64 already installed and latest version
No package krb5-dev available.
Package flex-2.5.35-8.el6.x86_64 already installed and latest version
No package glibc-dev available.
No package expat-dev available.
No package libstdc++-devel.x64_64 available.
No package xorg-x11-devel available.
Package libcap-devel-2.16-5.5.el6.x86_64 already installed and latest version
Package libtool-ltdl-2.2.6-15.5.el6.x86_64 already installed and latest version
No package libssl-dev available.
No package libopenssl0-devel available.
No package zlib1-devel available.
Package expat-devel-2.0.1-11.el6_2.x86_64 already installed and latest version
No package libopenssl0-dev available.
Package glibc-devel-2.12-1.132.el6.x86_64 already installed and latest version
Package expat-2.0.1-11.el6_2.x86_64 already installed and latest version
Package bison-2.4.1-5.el6.x86_64 already installed and latest version
No package libtool-libltdl-devel available.
Package libtool-2.2.6-15.5.el6.x86_64 already installed and latest version
No package openssl-dev available.
No package libopenssl0 available.
No package libz-devel available.
No package libjpeg-dev available.
No package pam-dev available.
No package libltdl-devel available.
No package libopenssl0.9.7-devel available.
No package ca_root_nss available.
Package libcap-2.16-5.5.el6.x86_64 already installed and latest version
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
No package libstdc++-dev.x86_64 available.
No package xorg-x11-dev available.
No package ssl-dev available.
No package lex available.
Package autoconf-2.63-5.1.el6.noarch already installed and latest version
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package automake.noarch 0:1.11.1-1.2.el6 will be updated
---> Package automake.noarch 0:1.11.1-4.el6 will be an update
---> Package coreutils.x86_64 0:8.4-19.el6 will be updated
--> Processing Dependency: coreutils = 8.4-19.el6 for package: coreutils-libs-8.4-19.el6.x86_64
---> Package coreutils.x86_64 0:8.4-31.el6 will be an update
---> Package cpp.x86_64 0:4.4.6-4.el6 will be updated
---> Package cpp.x86_64 0:4.4.7-4.el6 will be an update
---> Package e2fsprogs-devel.x86_64 0:1.41.12-12.el6 will be updated
---> Package e2fsprogs-devel.x86_64 0:1.41.12-18.el6 will be an update
--> Processing Dependency: libcom_err-devel = 1.41.12-18.el6 for package: e2fsprogs-devel-1.41.12-18.el6.x86_64
--> Processing Dependency: e2fsprogs-libs = 1.41.12-18.el6 for package: e2fsprogs-devel-1.41.12-18.el6.x86_64
---> Package gcc.x86_64 0:4.4.6-4.el6 will be updated
--> Processing Dependency: gcc = 4.4.6-4.el6 for package: gcc-objc-4.4.6-4.el6.x86_64
---> Package gcc.x86_64 0:4.4.7-4.el6 will be an update
--> Processing Dependency: libgomp = 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64
--> Processing Dependency: libgcc >= 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64
---> Package gcc-c++.x86_64 0:4.4.6-4.el6 will be updated
---> Package gcc-c++.x86_64 0:4.4.7-4.el6 will be an update
--> Processing Dependency: libstdc++-devel = 4.4.7-4.el6 for package: gcc-c++-4.4.7-4.el6.x86_64
---> Package gd.x86_64 0:2.0.35-10.el6 will be updated
--> Processing Dependency: gd = 2.0.35-10.el6 for package: gd-devel-2.0.35-10.el6.x86_64
--> Processing Dependency: gd = 2.0.35-10.el6 for package: gd-progs-2.0.35-10.el6.x86_64
---> Package gd.x86_64 0:2.0.35-11.el6 will be an update
---> Package krb5-devel.x86_64 0:1.9-33.el6_3.3 will be updated
---> Package krb5-devel.x86_64 0:1.10.3-10.el6_4.6 will be an update
--> Processing Dependency: krb5-libs = 1.10.3-10.el6_4.6 for package: krb5-devel-1.10.3-10.el6_4.6.x86_64
--> Processing Dependency: libkdb5.so.6()(64bit) for package: krb5-devel-1.10.3-10.el6_4.6.x86_64
---> Package libX11-devel.x86_64 0:1.3-2.el6 will be updated
---> Package libX11-devel.x86_64 0:1.5.0-4.el6 will be an update
--> Processing Dependency: libX11 = 1.5.0-4.el6 for package: libX11-devel-1.5.0-4.el6.x86_64
---> Package libXpm.x86_64 0:3.5.8-2.el6 will be updated
---> Package libXpm.x86_64 0:3.5.10-2.el6 will be an update
---> Package libXpm-devel.x86_64 0:3.5.8-2.el6 will be updated
---> Package libXpm-devel.x86_64 0:3.5.10-2.el6 will be an update
---> Package libjpeg-devel.x86_64 0:6b-46.el6 will be obsoleted
---> Package libjpeg-turbo-devel.x86_64 0:1.2.1-3.el6_5 will be obsoleting
--> Processing Dependency: libjpeg-turbo(x86-64) = 1.2.1-3.el6_5 for package: libjpeg-turbo-devel-1.2.1-3.el6_5.x86_64
---> Package libstdc++.x86_64 0:4.4.6-4.el6 will be updated
---> Package libstdc++.x86_64 0:4.4.7-4.el6 will be an update
---> Package openssl.x86_64 0:1.0.0-25.el6_3.1 will be updated
---> Package openssl.x86_64 0:1.0.1e-16.el6_5.4 will be an update
---> Package openssl-devel.x86_64 0:1.0.0-25.el6_3.1 will be updated
---> Package openssl-devel.x86_64 0:1.0.1e-16.el6_5.4 will be an update
---> Package pam-devel.x86_64 0:1.1.1-10.el6_2.1 will be updated
---> Package pam-devel.x86_64 0:1.1.1-17.el6 will be an update
--> Processing Dependency: pam = 1.1.1-17.el6 for package: pam-devel-1.1.1-17.el6.x86_64
---> Package zlib.x86_64 0:1.2.3-27.el6 will be updated
---> Package zlib.x86_64 0:1.2.3-29.el6 will be an update
---> Package zlib-devel.x86_64 0:1.2.3-27.el6 will be updated
---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be an update
--> Running transaction check
---> Package coreutils-libs.x86_64 0:8.4-19.el6 will be updated
---> Package coreutils-libs.x86_64 0:8.4-31.el6 will be an update
---> Package e2fsprogs-libs.i686 0:1.41.12-12.el6 will be updated
--> Processing Dependency: e2fsprogs-libs = 1.41.12-12.el6 for package: e2fsprogs-1.41.12-12.el6.x86_64
---> Package e2fsprogs-libs.x86_64 0:1.41.12-12.el6 will be updated
---> Package e2fsprogs-libs.i686 0:1.41.12-18.el6 will be an update
--> Processing Dependency: libcom_err = 1.41.12-18.el6 for package: e2fsprogs-libs-1.41.12-18.el6.i686
---> Package e2fsprogs-libs.x86_64 0:1.41.12-18.el6 will be an update
---> Package gcc-objc.x86_64 0:4.4.6-4.el6 will be updated
---> Package gcc-objc.x86_64 0:4.4.7-4.el6 will be an update
--> Processing Dependency: libobjc = 4.4.7-4.el6 for package: gcc-objc-4.4.7-4.el6.x86_64
---> Package gd-devel.x86_64 0:2.0.35-10.el6 will be updated
---> Package gd-devel.x86_64 0:2.0.35-11.el6 will be an update
---> Package gd-progs.x86_64 0:2.0.35-10.el6 will be updated
---> Package gd-progs.x86_64 0:2.0.35-11.el6 will be an update
---> Package krb5-libs.x86_64 0:1.9-33.el6_3.3 will be updated
---> Package krb5-libs.x86_64 0:1.10.3-10.el6_4.6 will be an update
---> Package libX11.x86_64 0:1.3-2.el6 will be updated
---> Package libX11.x86_64 0:1.5.0-4.el6 will be an update
--> Processing Dependency: libX11-common = 1.5.0-4.el6 for package: libX11-1.5.0-4.el6.x86_64
---> Package libcom_err-devel.x86_64 0:1.41.12-12.el6 will be updated
---> Package libcom_err-devel.x86_64 0:1.41.12-18.el6 will be an update
---> Package libgcc.i686 0:4.4.6-4.el6 will be updated
---> Package libgcc.x86_64 0:4.4.6-4.el6 will be updated
---> Package libgcc.i686 0:4.4.7-4.el6 will be an update
---> Package libgcc.x86_64 0:4.4.7-4.el6 will be an update
---> Package libgomp.x86_64 0:4.4.6-4.el6 will be updated
---> Package libgomp.x86_64 0:4.4.7-4.el6 will be an update
---> Package libjpeg.x86_64 0:6b-46.el6 will be obsoleted
---> Package libjpeg-turbo.x86_64 0:1.2.1-3.el6_5 will be obsoleting
---> Package libstdc++-devel.x86_64 0:4.4.6-4.el6 will be updated
---> Package libstdc++-devel.x86_64 0:4.4.7-4.el6 will be an update
---> Package pam.x86_64 0:1.1.1-10.el6_2.1 will be updated
---> Package pam.x86_64 0:1.1.1-17.el6 will be an update
--> Running transaction check
---> Package e2fsprogs.x86_64 0:1.41.12-12.el6 will be updated
---> Package e2fsprogs.x86_64 0:1.41.12-18.el6 will be an update
--> Processing Dependency: libss = 1.41.12-18.el6 for package: e2fsprogs-1.41.12-18.el6.x86_64
---> Package libX11-common.noarch 0:1.3-2.el6 will be updated
---> Package libX11-common.noarch 0:1.5.0-4.el6 will be an update
---> Package libcom_err.i686 0:1.41.12-12.el6 will be updated
---> Package libcom_err.x86_64 0:1.41.12-12.el6 will be updated
---> Package libcom_err.i686 0:1.41.12-18.el6 will be an update
---> Package libcom_err.x86_64 0:1.41.12-18.el6 will be an update
---> Package libobjc.x86_64 0:4.4.6-4.el6 will be updated
---> Package libobjc.x86_64 0:4.4.7-4.el6 will be an update
--> Running transaction check
---> Package libss.x86_64 0:1.41.12-12.el6 will be updated
---> Package libss.x86_64 0:1.41.12-18.el6 will be an update
--> Finished Dependency Resolution
Error: Protected multilib versions: libstdc++-4.4.7-4.el6.x86_64 != libstdc++-4.4.6-4.el6.i686
Error: Protected multilib versions: zlib-1.2.3-29.el6.x86_64 != zlib-1.2.3-27.el6.i686
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
!! ensure() rc was '0', exit status was '256', perl '$?' was '0', exit sig '0', core dump: '0', shell '$?' was '1' !!

!! Simulating failed Cpanel::SysPkgs as per 'simulate-failed-syspkgs' flag !!

!! Could not ensure pkglist 'automake19, gettext, libstdc++.x86_64, libpng-devel, readline-devel, openssl, libpng-dev, zlib-devel, autoconf261, libidn-devel, gmake, libidn, libXpm, openssl-devel, automake, coreutils, patch, libltdl3-devel, libltdl, libopenssl0.9.7-static-devel, readline-dev, libtool-ltdl-devel, libXpm-devel, sed, libXpm-dev, lsof, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, libstdc++-devel.x64_64, xorg-x11-devel, libcap-devel, libtool-ltdl, libssl-dev, pam-devel, libopenssl0-devel, zlib1-devel, expat-devel, libopenssl0-dev, glibc-devel, expat, gcc-c++, zlib, bison, libjpeg-devel, libtool-libltdl-devel, libtool, openssl-dev, libopenssl0, libz-devel, libjpeg-dev, pam-dev, fileutils, libltdl-devel, libopenssl0.9.7-devel, e2fsprogs-devel, ca_root_nss, libcap, make, libstdc++-dev.x86_64, libX11-devel, gd, cpp, xorg-x11-dev, gcc, ssl-dev, lex, autoconf' !!
!! The server's system package manager, 'YUM', failed. !!

!! 
This is the command that failed: yum -y install automake19 gettext libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev libtool-ltdl-devel libXpm-devel sed libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 xorg-x11-devel libcap-devel libtool-ltdl libssl-dev pam-devel libopenssl0-devel zlib1-devel expat-devel libopenssl0-dev glibc-devel expat gcc-c++ zlib bison libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel ca_root_nss libcap make libstdc++-dev.x86_64 libX11-devel gd cpp xorg-x11-dev gcc ssl-dev lex autoconf !!

!! 
Since EasyApache was unable to resolve it automatically you should: 1) Manually run the failed YUM command (shown above) via SSH 2) See if your particular error is addressed at http://go.cpanel.net/eaerror 3) Resolve the YUM problem manually 4) Re-run EasyApache !!

!! Please visit http://go.cpanel.net/eaerror for help with this error. !!

!! Restoring original working apache !!

!! Executing '/scripts/initsslhttpd' !!
!! Restarting 'httpd' ... !!
!! 'httpd' restart complete. !!
Building global cache for cpanel...Done
!! Executing '/scripts/initfpsuexec' !!
!! Executing '/scripts/initsslhttpd' !!
!! Executing '/scripts/update_apachectl' !!
Compiling report...
Sending report. As some of the attached files may be quite large, this could take a few minutes. Thanks for your patience.
Report processed.
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1390559566' !!
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,233
363
cPanel Access Level
DataCenter Provider
Twitter
Hello :)

The issue is that your system package manager (YUM) is unable to update successfully due to multiple installations (32-bit and 64-bit) of the same RPM. You can try running:

Code:
yum update libgcc
yum update zlib
However, it's likely you will need to check to see which architecture your system uses with a command such as:

Code:
uname -a
Then, remove the duplicate RPMs that do not match the architecture. You may want to get assistance with this from your data center or hosting provider as removing the wrong RPM can result is OS-level errors.

Thank you.