EasyApache Upgrade Fails & YUM Fails

Edrick Smith

Registered
Oct 9, 2017
4
0
1
Boston, MA
cPanel Access Level
DataCenter Provider
So I started by trying to just run EasyApache through the upgrade of the existing packages however I get the following;

[2019-02-26 23:53:56 -0500] info [xml-api] ea-libnghttp2(x86-64) = 1.32.0-1.1.4.cpanel
[2019-02-26 23:53:56 -0500] info [xml-api] Leaving Shell

Error: Package: ea-nghttp2-1.32.0-1.1.3.cpanel.x86_64 (@EA4)
Requires: ea-libnghttp2(x86-64) = 1.32.0-1.1.3.cpanel
Removing: ea-libnghttp2-1.32.0-1.1.3.cpanel.x86_64 (@EA4)
ea-libnghttp2(x86-64) = 1.32.0-1.1.3.cpanel
Updated By: ea-libnghttp2-1.32.0-1.1.5.cpanel.x86_64 (EA4)
ea-libnghttp2(x86-64) = 1.32.0-1.1.5.cpanel
Available: ea-libnghttp2-1.20.0-7.7.1.cpanel.x86_64 (EA4)
ea-libnghttp2(x86-64) = 1.20.0-7.7.1.cpanel
Available: ea-libnghttp2-1.20.0-8.8.3.cpanel.x86_64 (EA4)
ea-libnghttp2(x86-64) = 1.20.0-8.8.3.cpanel
Available: ea-libnghttp2-1.20.0-8.8.4.cpanel.x86_64 (EA4)
ea-libnghttp2(x86-64) = 1.20.0-8.8.4.cpanel
Available: ea-libnghttp2-1.32.0-1.1.4.cpanel.x86_64 (EA4)
ea-libnghttp2(x86-64) = 1.32.0-1.1.4.cpanel
The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2019-02-26_23:53:56-1

Provision process finished.



----

When trying to run yum for updates also I get a numerous amount of x is a duplicate with x

1:perl-IO-Zlib-1.10-294.el7_6.noarch is a duplicate with 1:perl-IO-Zlib-1.10-293.el7.noarch
1:perl-Locale-Maketext-Simple-0.21-294.el7_6.noarch is a duplicate with 1:perl-Locale-Maketext-Simple-0.21-293.el7.noarch
1:perl-Module-CoreList-2.76.02-294.el7_6.noarch is a duplicate with 1:perl-Module-CoreList-2.76.02-293.el7.noarch
1:perl-Module-Loaded-0.08-294.el7_6.noarch is a duplicate with 1:perl-Module-Loaded-0.08-293.el7.noarch
1:perl-Object-Accessor-0.42-294.el7_6.noarch is a duplicate with 1:perl-Object-Accessor-0.42-293.el7.noarch
1:perl-Package-Constants-0.02-294.el7_6.noarch is a duplicate with 1:perl-Package-Constants-0.02-293.el7.noarch
1:perl-Pod-Escapes-1.04-294.el7_6.noarch is a duplicate with 1:perl-Pod-Escapes-1.04-293.el7.noarch
perl-Time-Piece-1.20.1-294.el7_6.x86_64 is a duplicate with perl-Time-Piece-1.20.1-293.el7.x86_64
4:perl-libs-5.16.3-294.el7_6.x86_64 is a duplicate with 4:perl-libs-5.16.3-293.el7.x86_64
4:perl-macros-5.16.3-294.el7_6.x86_64 is a duplicate with 4:perl-macros-5.16.3-293.el7.x86_64
policycoreutils-2.5-29.el7_6.1.x86_64 is a duplicate with policycoreutils-2.5-29.el7.x86_64
policycoreutils-python-2.5-29.el7_6.1.x86_64 is a duplicate with policycoreutils-python-2.5-29.el7.x86_64
selinux-policy-3.13.1-229.el7_6.9.noarch is a duplicate with selinux-policy-3.13.1-229.el7_6.6.noarch

-----

Which also causes YUM to error out, I tried rebuilding the RPM database in WHM.


Any ideas?
 

Edrick Smith

Registered
Oct 9, 2017
4
0
1
Boston, MA
cPanel Access Level
DataCenter Provider
Hi @Edrick Smith

What version of libnghttp2 is present now?

Code:
rpm -qa |grep ea-libnghttp2
You need to remove the duplicates in this instance some advice on this is given in the following thread: SOLVED - Error updating cPanel RPM issue
[email protected] [~]# rpm -qa |grep ea-libnghttp2
ea-libnghttp2-1.32.0-1.1.5.cpanel.x86_64


---


That's the output after running the command to remove dupes from that post.

Finally have gotten easy apache to rebuild and update,

However ym still fails;

Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-composer(symfony/console) < 5.0
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(phpdocumentor/reflection-docblock) >= 2.0
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-composer(jakub-onderka/php-console-highlighter) >= 0.3.0
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-composer(symfony/var-dumper) < 5.0
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(pear/console_table) >= 1.3.0
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-posix
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-readline
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-composer(symfony/var-dumper) >= 2.7.1
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(phpdocumentor/reflection-docblock) < 3.0
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(fedora/autoloader)
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(symfony/finder) < 3.0
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(consolidation/output-formatters) < 4
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(consolidation/annotated-command) >= 2
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(symfony/var-dumper) < 3.0
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-posix
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(symfony/yaml) < 3.0
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(symfony/console) >= 2.7.1
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(webmozart/path-util) >= 2
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-composer(jakub-onderka/php-console-highlighter) < 0.4.0
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-composer(dnoegel/php-xdg-base-dir) < 0.2
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(consolidation/output-formatters) >= 3
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(phpunit/phpunit)
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(symfony/console) < 3.0
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-composer(dnoegel/php-xdg-base-dir) >= 0.1
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-pcntl
Error: Package: drush-8.1.10-1.el7.noarch (epel)
Requires: php-composer(webmozart/path-util) < 3
Error: Package: psysh-0.8.16-1.el7.noarch (epel)
Requires: php-composer(nikic/php-parser) < 4.0
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-headers-3.10.0-957.5.1.el7.x86_64 is a duplicate with kernel-headers-3.10.0-957.1.3.el7.x86_64
[email protected] [~]#
 
Last edited:

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,110
660
263
Houston
cPanel Access Level
DataCenter Provider
Finally have gotten easy apache to rebuild and update,
I'm really glad to hear that!

However ym still fails;
The packages it's trying to install are requiring dependencies to be resolved and I believe they're these packages:

Code:
Requires: php-composer
Requires: php-posix
Requires: php-readline
Requires: php-pcntl

Are any of these installed on the system right now?

Code:
rpm -qa |egrep 'composer|posix|readline|pcntl'
 

Edrick Smith

Registered
Oct 9, 2017
4
0
1
Boston, MA
cPanel Access Level
DataCenter Provider
I'm really glad to hear that!


The packages it's trying to install are requiring dependencies to be resolved and I believe they're these packages:

Code:
Requires: php-composer
Requires: php-posix
Requires: php-readline
Requires: php-pcntl

Are any of these installed on the system right now?

Code:
rpm -qa |egrep 'composer|posix|readline|pcntl'

cpanel1 [~]# rpm -qa |egrep 'composer|posix|readline|

cpanel-php-composer-1.7.2-1.cp1176.noarch
readline-6.2-10.el7.x86_64
ea-php71-php-posix-7.1.26-2.2.6.cpanel.x86_64
ea-php72-php-posix-7.2.15-1.1.5.cpanel.x86_64
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,110
660
263
Houston
cPanel Access Level
DataCenter Provider
I would say it's a repo issue, epel is a 3rd party repository though it may be beneficial to have one of our analysts take a closer look if you like.
Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!