The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Easyapache upgrade failure when selecting ModSecurity

Discussion in 'EasyApache' started by BlackRain, Apr 29, 2013.

  1. BlackRain

    BlackRain Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    After all these years of using Cpanel, I finally have had a disaster using Easyapache.

    Here are my details:

    Code:
    CENTOS 5.9 i686 standard – WHM 11.36.1 (build 5) 
    Server Version: Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
    
    I tried to update my Apache software using the Cpanel Easyapache and it died. It would not update because I had selected the ModPerl option due to a inability to install a module

    When I deselected ModPerl, I tried again and the Easyapache process died when it got to the ModSecurity install stage giving the error:

    I have run Yum Update and it state none are available.


    I tried to manually install the missing modules using CPAN but that also gives an error:


    Anyone have an idea to get ModSecurity working again due to this Easyapache failure?

    Thanks!
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. BlackRain

    BlackRain Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Thanks for the reply. However it is not a Mod Security rules issue. It's an installation issue. ModSecurity won't install because their is a missing dependency somewhere as I posted above.

    On my latest attempt to use EasyApache, it quit on the ModSecurity install because GnuGp was missing however I confirmed that is indeed installed.

    Still have no idea what to do.
     
  4. BlackRain

    BlackRain Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Here are my Perl details

    # /usr/bin/perl -v

    # /usr/local/bin/perl -v



    ls -l /usr/bin/perl /usr/local/bin/perl


    # rpm -qf /usr/bin/perl
    # cat /usr/local/cpanel/version
     
    #4 BlackRain, Apr 30, 2013
    Last edited: Apr 30, 2013
  5. BlackRain

    BlackRain Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Is this correct? I have a feeling that having two Perl versions installed at /usr/bin/perl and usr/local/bin/perl is borking the install.

    # which perl
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  7. BlackRain

    BlackRain Well-Known Member

    Joined:
    May 28, 2003
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    I did get it working eventually, can't actually say which change I made did the trick as I was up till 2AM last night trying to fix the problem.

    The EasyApache upgrade process failed. It required a lot of manual corrections and testing in order to get a new Apache build working. This is the first time I can remember that Easyapache failed in my history with Cpanel.

    Things I noticed.

    1) Upgrade to lastest PHP ALSO required upgrade of MySql to 5.5 from the 5.1 I had previously.
    2) Mod_Perl can not be used in latest Cpanel 11.36 Easyapache function. There should be a notice in the build options.

    3) Mod_Security could not be built into latest Apache build due to missing Perl modules. They had to be found and installed manually.
    I can not see how a novice Cpanel user could do this update without a support ticket.
     
  8. ScottTh

    ScottTh Well-Known Member

    Joined:
    Jan 28, 2013
    Messages:
    157
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Hi BlackRain,

    I'm sorry to hear that you were having some issues with EasyApache. Thank you for your suggestion about including a notice about mod_perl and the latest version of cPanel 11.36. Infopro's link to the post about preparing for 11.36 is helpful http://forums.cpanel.net/f133/prepare-your-perl-scripts-11-36-a-311202.html but as you mentioned, a notice in the build options page could also be helpful.

    I'm happy to see that you were able to successfully build EasyApache and in the future please feel free to open a support ticket with us. The techs are tremendous and have a lot of knowledge about EasyApache.

    Please let us know if you have any additional questions about this particular EasyApache rebuilding project.
     
Loading...

Share This Page