amelen

Active Member
Sep 15, 2003
36
0
156
I can't seem to get WHM to build apache. I have tried setting it to the most basic settings with no modules, etc.. being installed. No matter what I do, I get this every single time:

Out of memory!
*** glibc detected *** realloc(): invalid next size: 0x274b53d0 ***
!! '/scripts/enablefileprotect' failed with exit code '134' !!
!! Restoring original working apache !!
!! Executing '/scripts/initfpsuexec' !!
!! Executing '/scripts/initsslhttpd' !!
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1193932410' !!


I opened a ticket with cpanel and they said it had to do with installing frontpage extentions. So I disabled frontpage, and still get the same error. I have ready every post on this in these forums so I have already tried executing in SSH instead of WHM, and I have tried increasing the memory usage allowed for a cpanel process from 256mb to 512mb. Any ideas?

The OS drive is a little full, but it should definitely have enough space for an apache upgrade!

/dev/sda5 13622372 11596864 1333512 90% /
 

mtindor

Well-Known Member
Sep 14, 2004
1,417
82
178
inside a catfish
cPanel Access Level
Root Administrator
Are you on a VPS running Cpanel? If so, your VPS might be such a low-end VPS package that it just isn't going to make anything easy for you.

Mike


I can't seem to get WHM to build apache. I have tried setting it to the most basic settings with no modules, etc.. being installed. No matter what I do, I get this every single time:

Out of memory!
*** glibc detected *** realloc(): invalid next size: 0x274b53d0 ***
!! '/scripts/enablefileprotect' failed with exit code '134' !!
!! Restoring original working apache !!
!! Executing '/scripts/initfpsuexec' !!
!! Executing '/scripts/initsslhttpd' !!
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1193932410' !!


I opened a ticket with cpanel and they said it had to do with installing frontpage extentions. So I disabled frontpage, and still get the same error. I have ready every post on this in these forums so I have already tried executing in SSH instead of WHM, and I have tried increasing the memory usage allowed for a cpanel process from 256mb to 512mb. Any ideas?

The OS drive is a little full, but it should definitely have enough space for an apache upgrade!

/dev/sda5 13622372 11596864 1333512 90% /
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
I can't seem to get WHM to build apache. I have tried setting it to the most basic settings with no modules, etc.. being installed. No matter what I do, I get this every single time:

Out of memory!
*** glibc detected *** realloc(): invalid next size: 0x274b53d0 ***
What is your OS? Is it fully updated? That looks like a glibc error present in older versions of CentOS/RHEL. See this for example:

http://www.google.com/search?q=glib...s=org.mozilla:en-US:official&client=firefox-a
 

infinityws

Well-Known Member
Feb 20, 2003
110
0
166
Didn't you say in another post to increase the amount of memory cpanel can use in tweak settings?
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Increasing the Max Memory a cPanel process can use, via Tweak Settings, can help for the WHM based Apache Update. SEtting it to 256 MB is the recommended minimum.
 

lyzer

Member
Aug 3, 2004
6
0
151
I'm having the same issue on my server whenever running the enablefileprotect scripts (as easyapache runs it) or standalone the glibc error presents itself. I've tried letting it use 4 gigs of memory in the cpanel limit and although the error says "out of memory" I watched enablefileprotect in top and it looked like it killed itself off at about 2 gigs of usage.

The box is running centos4 and is completely up to date according to yum.

Any ideas??
 
Last edited:

lyzer

Member
Aug 3, 2004
6
0
151
I don't think so simply because the issue isn't with the easyapache script it's with the enablefileprotect script. When you run it the following happens:

Setting /home permissions to 0711......Done
Setting permissions for....user1....user2.....user3.....user4.....user5.....Out of memory!

Then it quits causing easyapache to fail as well which throws the glibc error. Also the error on that bug errata is different than the one in this thread.
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
If you are still experiencing this issue, you may wish to submit a ticket directly to cPanel so our support staff can login to your server and diagnose what precisely may be causing this and determine the appropriate corrective action.
 

cPDan

cPanel Staff
Staff member
Mar 9, 2004
721
13
243
I'm having the same issue on my server whenever running the enablefileprotect scripts (as easyapache runs it) or standalone the glibc error presents itself. I've tried letting it use 4 gigs of memory in the cpanel limit and although the error says "out of memory" I watched enablefileprotect in top and it looked like it killed itself off at about 2 gigs of usage.

The box is running centos4 and is completely up to date according to yum.

Any ideas??
ticket number?