easyapache wont update after mysqlup to mysql5

Snowman30

Well-Known Member
PartnerNOC
Apr 7, 2002
679
0
316
cPanel Access Level
DataCenter Provider
Got a very strange problems on a Centos 3.7 server running the latest stable cpanel

ive just upgraded mySQL to v5.x and ran easyapache and i get the following error:

********************************
This is buildapache version 1.5.402 (for cpanel <= 10.9.3) (ap=1.3.36)
********************************
buildapache configured from Web Host Manager
Apache configured from Web Host Manager!
Invalid Configuration: php-505 blocks install because [MySQL 5.0.21 or later required.]
strange thing is the servers already running php 5.0.5

anyone have any ideas?
 

Snowman30

Well-Known Member
PartnerNOC
Apr 7, 2002
679
0
316
cPanel Access Level
DataCenter Provider
actually now im completely confused.

easyapache is telling me MySQL 5.0.21 is required but the 2 servers ive just updated within 5 mins of each other have 2 different versions 5.0.18 and 5.0.19

this is getitng weirder by the minute

anyone else having these issues?
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,462
25
473
Go on, have a guess
Odd. Mine auto-upped to 5.0.21 IIRC. Did you try it with --force? I wonder if they're rolling it out to their update mirrors and it hasn't got all the way around or something.
 

hostproof

Member
Mar 9, 2003
21
0
151
Europe
This difference is because you will get these versions for mysql:

cpanel edge build: mysql 5.0.21
cpanel stable build: mysql 5.0.18
cpanel release build: mysql 5.0.18

Personally I hope they upgrade to 5.0.22 real soon as there is a silly bug in all previous version that affected two of my bigger forums (i solved it by doing a mysqldmp und realoading the database): http://bugs.mysql.com/bug.php?id=17810
 

Snowman30

Well-Known Member
PartnerNOC
Apr 7, 2002
679
0
316
cPanel Access Level
DataCenter Provider
ok so why do i have 2 servers running:

WHM 10.8.0 cPanel 10.8.2-S120
CentOS 3.7 i686 - WHM X v3.1.0

One has Mysql 5.0.18 and the second has 5.0.19

doesnt make sense...

I can understand if its only in the edge build (god i wish they would mention this sort of thing in the changelog)
 

akrzystek

Member
Jul 8, 2005
15
0
151
Hi

I've got the same problem:

********************************
This is buildapache version 1.5.402 (for cpanel <= 10.9.3) (ap=1.3.36)
********************************
buildapache configured from Web Host Manager
Apache configured from Web Host Manager!
Invalid Configuration: php-514 blocks install because [MySQL 4.1.19 or later required.]

/scripts/mysqlup
MySQL Setup Script Version 7.0
This is the MySQL installer for OS FreeBSD
mysql-client-4.1 (4.1.10a) is already installed.
mysql-client-4.1 (4.1.10a) is already installed.
mysql-server-4.1 (4.1.15) is newer then requested version 4.1.10a. (no install needed)
mysql-server-4.1 (4.1.15) is newer then requested version 4.1.10a. (no install needed)
Install Complete

Would it be a good idea to update mysql from freebsd ports? Or would this break things in cpanel?
Or, even better, is there a way to force the mysql update with /scripts/mysqlup (--force does not help)?
 

skripx

Member
Sep 23, 2004
11
0
151
Mine worked fine!
All i did was select "Manual Updates Only (bleeding EDGE tree)" in WHM under "Update Config" then I ran the update script once agian and it went to 5.0.21.
 

Snowman30

Well-Known Member
PartnerNOC
Apr 7, 2002
679
0
316
cPanel Access Level
DataCenter Provider
skripx said:
Mine worked fine!
All i did was select "Manual Updates Only (bleeding EDGE tree)" in WHM under "Update Config" then I ran the update script once agian and it went to 5.0.21.
Thats fine if you want to run Edge, but anyone that runs edge on a populated production server is just asking for trouble
 

cod3x

Registered
Oct 4, 2003
1
0
151
Try going into WHM's Update Config and setting it to 'Manual Updates Only (bleeding EDGE tree)'. Then run the command '/scripts/mysqlup --force'. Once this has completed set your Update Config back to the previous setting.