The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

easyapache

Discussion in 'EasyApache' started by 3amp, Nov 27, 2003.

  1. 3amp

    3amp Member

    Joined:
    Jun 9, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I need to install Apache with Curl, Curl SSL and Mcrypt. If I choose option 5 with easyapache, it doesn't install curl... I tried, but i get curl_init errors.

    So I'll have to go with advanced install (6) but don't know which options to select besides the above mentioned...does anyone know the list of the modules I should definately have???

    2) And what is phpsuexec for and suexec?
    3) what's the option 'use system sql' for..I mean, if I do not select it, how will sql be used?

    Any tips/advise/manuals welcome
    thanks

    stepan


    __________________
     
  2. srufiange

    srufiange Registered

    Joined:
    Jul 10, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here

    I just reinstalled cpanel and same problem here is happening.

    I get curl_init() function not found errors and I need it.

    Anyone found a solution?

    Thanks,

    srufiange
     
  3. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    It is still broken. I have found that you can upgrade to 4.3.4 if it is the only extra option you select. Then you can add curl and other options as long as you select them one at a time. Takes a bunch of compiles.
     
  4. orb_sp

    orb_sp Active Member

    Joined:
    Aug 7, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6

    I've got the same problem. It's rather unpleasant having to spend that much time recompiling for features that should be able to be compiled together.

    And to think that I once thought that cPanel was produced to assist with helping people administer the server with ease.
     
  5. NeutralGold

    NeutralGold Well-Known Member

    Joined:
    Jun 5, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    I'm not sure the problem you guys are having, but I compile everything all at once and it works just fine and dandy. Blaming cPanel won't get you to far in trying to figure out what the real issue is.
     
  6. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Nice post Neutral, but I would be glad to forward you a copy of the ticket admitting there is a problem. Once the items are compiled in they will stay as long as you keep them selected. The problem is that you have to compile multiple times to add new features. We are getting this on RHE so that may be a difference in your config also. Basically before you post something like that you should do a little research.
     
  7. orb_sp

    orb_sp Active Member

    Joined:
    Aug 7, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Good call Kris. My response wasn't quite that nice so I'll just go with what you've said.
     
  8. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Haha, I know your frustration. We have a few clients that run very demanding sites and this has really made a mess after we upgraded several servers to RHE. There was another buildapache.sea upgrade yesterday so maybe it has what we need. Am running it on the test server now.
     
  9. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    FWIW, I was having some problems as well, but I got a ntoe today that indicates that it was fixed this morning. Run uodatenow and then try easyapache. Worked great for me.
     
  10. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    We have a server we run on Edge, will have to try it out in the morning.
     
  11. orb_sp

    orb_sp Active Member

    Joined:
    Aug 7, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    How did you go with this Kris?
     
  12. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    The release updates now will compile 4.3.4 and every other option in without multiple compiles. We have tested this on a 7.3, 9.0 and RHE server. You should be good to recompile.
     
  13. orb_sp

    orb_sp Active Member

    Joined:
    Aug 7, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    That's wonderful news. Thanks for being the guinea pig.
     
  14. orb_sp

    orb_sp Active Member

    Joined:
    Aug 7, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    It doesn't appear to work for me. PSPELL and it looks like Flash maybe causing me trouble. I'm on RHE3 though.
     
  15. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    I left psspell out of the configs on ours also. Just with all the previous warnings I didn't see a big need for it. Flash compiled right in though.
     
  16. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    don't compile psspell as of now. I had easyapache fail with several boxes. Deselecting psspell, solved it. Flash was np at all.

    don't know abt RHE as kris1351, so can't say nething abt it.
     
  17. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    I have got a few RH9 boxes that I could nto get pspell compiled into either, but they work on my rhel box. Go figure.
     
  18. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    i am not disagreeing.
     
  19. orb_sp

    orb_sp Active Member

    Joined:
    Aug 7, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    I wish pspell was the only module that mine wouldn't compile with. Mine is much more temperamental than that.
     
  20. liquidcherry

    liquidcherry Well-Known Member

    Joined:
    Jan 20, 2004
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    hello orb....

    did you resolve this prob?
    If not i had a similar issue......
    I couldnt either change the php versions so i downgraded from 4.3.3 to 4.3.2,that worked....
    I tryed it again to get 4.3.4,no chance...
    Than i recompiled it again to become 4.3.4 but without php accidantelly :) (it was funny , after loosing php i could save all the time the phpinfo file what i tryed to view in the browser,didnt knew that.....)
    Then i recompiled with the option to get 4.3.4 only.....and it worked.....
    After that i tryed to choose almost all without a few options......no chance.....
    And finally i choosed a few

    ('./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-swf=/usr/local/flash' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--enable-magic-quotes' '--with-mysql=/usr' '--with-openssl' '--with-pear' '--enable-safe-mode' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib' )



    and this did it......


    Frank

    cPanel.net Support Ticket Number: maybe this helps...
     
Loading...

Share This Page