The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache2 Error...

Discussion in 'EasyApache' started by Nhojohl, Jan 29, 2007.

  1. Nhojohl

    Nhojohl Well-Known Member

    Joined:
    Nov 28, 2006
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    16
    I've got a test server with Edge installed and just one account on it that I use for test junk. I just upgraded it to edge the other day and whenever I try to run the apache update I get the following error:

    Code:
        Saving configuration...
    Building configuration...
    
    **** Building Apache 1 **
    
    ---- --
    Running Adding --enable-sockets support...
    
    	to config options...
    End Adding --enable-sockets support
    ---- --
    
    ---- --
    Running Adding --enable-bcmath support...
    
    	to config options...
    End Adding --enable-bcmath support
    ---- --
    
    ---- --
    Running Adding --with-mysql support...
    
    	to config options...
    End Adding --with-mysql support
    ---- --
    
    ---- --
    Running Adding --enable-magic-quotes support...
    
    	to config options...
    End Adding --enable-magic-quotes support
    ---- --
    
    ---- --
    Running Adding --enable-calendar support...
    
    	to config options...
    End Adding --enable-calendar support
    ---- --
    
    Could not load Apache1::XPHP__5_1_6__S::With_Pear (/home/cpeasyapache/work/cPanelEA/Apache1/XPHP__5_1_6__S/With_Pear.pm). Ignoring...
    ---- --
    Running Adding --enable-discard-path support...
    
    	to config options...
    End Adding --enable-discard-path support
    ---- --
    
    ---- --
    Running Adding --with-zlib support...
    
    	to config options...
    Loading "fastestmirror" plugin
    Setting up Install Process
    Setting up repositories
    Loading mirror speeds from cached hostfile
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Nothing to do
    Looking for libXpm.so in /lib...not found.
    Looking for libXpm.so in /usr/lib...not found.
    Looking for libXpm.so in /usr/local/lib...not found.
    !!!! If you receive libXpm related errors ensure that the file mentioned in the error exists and is accessable. It may be that libXpm and/or libXpm-devel need installed !!
    
    End Adding --with-zlib support
    ---- --
    
    ---- --
    Running Adding --enable-ftp support...
    
    	to config options...
    End Adding --enable-ftp support
    ---- --
    
    ---- --
    Running Adding frontpage...
    
    	Preparing Server for FP...
    	to static mods...
    End Adding frontpage
    ---- --
    
    ---- --
    Running PHP 5 support...
    
    	adding to "do in src tree" list...
    End PHP 5 support
    ---- --
    
    ---- --
    Running Webroot protection...
    
    	setting it up...
    
    Done!
    
    End Webroot protection
    ---- --
    
    ---- --
    Running Apache 1 httpd core...
    
    	Setting up SSL...
    		Building mod_ssl..
    
    Done!
    
    		Done Building mod_ssl
    	Applying patches if any...
    Setting /home permissions to 0711......Done
    Setting permissions for.....netwaveh...aliclot...anthony1...anthony3...anthony4...anthony2...hijosde...johnohl...theycal...thenumb...heart...round5s...robbie...graylik...mangop...itch...xtratic...xsquad9...baseerak...elxremco...pnonet...xtraticw...wwwfear......Done
    
    Done!
    
    Done!
    
    Done!
    
    Done!
    
    	Doing module tasks that require apache source...
    			./configure
    			--with-prefix=/usr/local
    			--with-apache=/home/cpeasyapache/work/cPanelEA/Apache1.pm.build/apache_1.3.37
    			--enable-libxml
    			--with-libxml-dir=/opt/xml2/
    			--enable-sockets
    			--enable-bcmath
    			--with-mysql
    			--with-mysqli
    			--enable-magic-quotes
    			--enable-calendar
    			--enable-discard-path
    			--with-zlib
    			--enable-ftp
    
    Done!
    
    Done!
    
    Done!
    
    	Configure Apache 1 source tree...
    		[easyapache] Building Apache 1 with:
    
    			--prefix=/usr/local/apache1
    			--logfiledir=/usr/local/apache/logs
    			--sysconfdir=/usr/local/apache/conf
    			--enable-suexec
    			--suexec-logfile=/usr/local/apache/logs/suexec_log
    			--suexec-caller=nobody
    			--suexec-uidmin=100
    			--suexec-gidmin=100
    			--suexec-docroot=/
    			--suexec-userdir=public_html
    			--enable-module=so
    			--enable-module=ssl
    			--enable-module=rewrite
    			--add-module=../mod_frontpage.c
    			--activate-module=src/modules/php5/libphp5.a
    
    Done!
    
    	Making Apache 1...
    
    Done!
    
    [COLOR="Red"][B]Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.[/B][/COLOR]
    	Installing Apache 1...
    
    Done!
    
    [COLOR="Red"][B]Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.
    Use of uninitialized value in -e at /usr/lib/perl5/site_perl/5.8.7/File/Copy/Recursive.pm line 196.[/B][/COLOR]
    Could not determine user for ServerName 'server.domain.com', defaulting to 'nobody' for server.domain.com at /usr/lib/perl5/site_perl/5.8.7/Apache/Admin/Config.pm line 217
    Adding VirtualHost entry for xsquad9 ... done
    httpd.conf SRC: 1 TRG: 1
    	Coercing apachectl...
    
    Done!
    
    	APXSing required mods...
    		adding module mod_auth_passthrough.c
    
    Done!
    
    		adding module mod_bwlimited.c
    
    Done!
    
    		adding module mod_log_bytes.c
    
    Done!
    
    End Apache 1 httpd core
    ---- --
    
    
    **** Done building apache 1, starting post run tasks **
    
    Cleaning up build directories...
    Done
    
    Done!
    
    Error: postcheck() returned a failed status
    	Restoring previously working apache
    Done!
    
    [Back]
    This happens when I try compiling with ANY of the PHP options, or any of the 3 apache versions. The odd thing is, is that if I downgrade to CURRENT or RELEASE and run apache update I can run the original easyapache without any problems at all...

    The box is a CentOS 4.4.


    Anyone got any ideas? I can't figure it out, I've tried searching for it....


    Thanks,
    John
     
  2. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    526
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Brno, Czech Republic
    this is one of the reasons why i compiled apache on current build, and then switched to edge build.
     
Loading...

Share This Page