The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

easyapache3 removing AddHandler from .htaccess

Discussion in 'EasyApache' started by s_rage, Dec 10, 2008.

  1. s_rage

    s_rage Member

    Joined:
    Jan 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Greetings, having a strange problem after running easyapache -- the .htaccess files in certain accounts are getting the "AddHandler" line automatically commented out. This has happened on two different servers. Not all of the .htaccess files are affected either. It happened to only one account (of about 30) on the first server, and two accounts (of about 50) on the second.

    Can anyone shed some insight on this?
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Adjust the value for the following tweak setting:

    The maximum number of directories deep to look for .htaccess files when doing .htaccess checks. Can be from 0 to 100. 2 is the default setting. Values higher than this are discouraged.
     
  3. s_rage

    s_rage Member

    Joined:
    Jan 4, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the response, but I don't see how the setting you mention has anything to do with my problem.

    Let me clarify, in case I wasn't specific enough in my initial post:

    All of my accounts have this line in their .htaccess:
    AddHandler application/x-httpd-php .html

    I ran easyapache, and when it completed that line was commented in out in one account's .htaccess:
    # AddHandler application/x-httpd-php .html

    The .htaccess files for all my other accounts were unchanged.
     
  4. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Did you enable SuPhp when you used easyapache?
     
  5. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,460
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    When the PHP handler is changed, the system is scanned for .htacess files that contain AddHandler entries. Ones that define an entry for handling PHP are commented out. This is done to prevent conflicts and other handling issues.

    To modify this behavior, change the tweak setting I mentioned in my prior post.
     
  6. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    I thought that was the case, which is why I had asked if he had changed his to SuPhp.
     
Loading...

Share This Page