Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EasyApache4 to EasyApache3

Discussion in 'EasyApache' started by Saeed eskandari, Dec 1, 2016.

  1. Saeed eskandari

    Joined:
    May 4, 2015
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Iran
    cPanel Access Level:
    DataCenter Provider
    Hello
    i install new whm
    i want install easyapache 3 please help me please
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can only uninstall EasyApache 4 if you migrated your system from EasyApache 3. Reverting to EasyApache 3 on new installations of cPanel is unsupported.

    Could you let us know what in-particular is leading you to prefer EasyApache 3 over EasyApache 4?

    Thank you.
     
  3. Saeed eskandari

    Joined:
    May 4, 2015
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Iran
    cPanel Access Level:
    DataCenter Provider
    i can not build easyapache 4 for ioncube loader
    it not sappurted
    [root@s ~]# /scripts/phpextensionmgr list
    This script is not supported in EasyApache 4 at this time
    OR.....
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    To install or uninstall the ionCube loaders in EasyApache 4, use WHM's EasyApache 4 interface (WHM Home >> Software >> EasyApache 4), or run the following command:

    Code:
    yum install ea-php56-php-ioncube
    Replace "php56" with the version of PHP you'd like to install it for. Please also see this document if you prefer to use a different IonCube version:

    PHP Loader: ionCube 5 - EasyApache 4 - cPanel Documentation

    Thank you.
     
  5. Saeed eskandari

    Joined:
    May 4, 2015
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Iran
    cPanel Access Level:
    DataCenter Provider
    SourceGuardian how install ?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    You'd use the same steps from my previous response, except with the different package name. EX:

    Code:
    yum install ea-php56-php-sourceguardian
    You may also find this document helpful to see which PHP versions are currently supported for SourceGuardian:

    PHP Options - EasyApache 4 - cPanel Documentation

    Note that support for SourceGuardian with PHP 7.0 is scheduled for inclusion with cPanel version 62.

    This document will let you know how to find and install specific packages with EasyApache 4:

    How to Locate and Install a PHP Version or Extension - EasyApache 4 - cPanel Documentation

    Thanks!
     
Loading...

Share This Page