The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

echo $LD_LIBRARY_PATH

Discussion in 'Database Discussions' started by Piratetrader, Feb 14, 2014.

  1. Piratetrader

    Piratetrader Registered

    Joined:
    Feb 12, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I am trying to set up a website that uses three different tools important to its use. One is a API system to keep the members of the site in the right user groups to access only the forums they need to be in. It also has a teamspeak3 connection that will make sure that the users are added to the right groups based off there API's and puts them in the right access channels in TS3. The last is Jabber which also will set them in the right groups. All of these require MySQL to work right. I have set up the website with MySQL and all went well and its up and running with rules, but I have found that I can not get it to install with the MySQL do to not being able to find the Database path and install the tables need.

    I have searched the web and worked on several different ways to make this happen. I am at a point that I have done a echo $PATH and all the right paths are there and then I did a echo $LD_LIBRARY_PATH and it comes back blank. I also have searched the web for answers and can not seem to get the info I need. I have put

    LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
    export LD_LIBRARY_PATH

    in the .bash_profile file and still get a blank response. I'm not sure what to try next any help would be great and thank you in advance.

    Piratetrader

    - - - Updated - - -

    Quick update I'm on a Dedicated CentOS 6 server supplied by Godaddy with cPanel and im using SSH to install TS3 server after I set up a MySQL database as it needs its own Database and does not add to the website Database.
     
  2. vanessa

    vanessa Well-Known Member
    PartnerNOC

    Joined:
    Sep 26, 2006
    Messages:
    817
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    Virginia Beach, VA
    cPanel Access Level:
    DataCenter Provider
    This is a little confusing. You're talking about a database path, but your later text implies that you're actually trying to get your software to find libraries. If the application is trying to install database tables, I don't see why TS3 would need any of this information. To install tables, it simply needs to know the database name and credentials so it can connect and do the needful.

    If this doesn't help, please provide information on exactly what you're trying to install, what errors you're getting. etc
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Have you reviewed the installation instructions for your application to verify the specific steps you must complete? It looks more like an issue with the script itself rather than with MySQL. For instance, what MySQL error messages do you receive, or what leads you to believe there is a problem with MySQL?

    Thank you.
     

Share This Page