The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Edit dns zone is empty

Discussion in 'Bind / DNS / Nameserver Issues' started by eth00, Jun 21, 2004.

  1. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    Ok awhile back I had dns clustering on the server but since then it has been removed. Suddenly the "edit dns setup" is broken in WHM and nothing displays. If I use WHM to "Add dns zone" I get the following error:


    It sounds like part of the clustering, but I never used dns master and cannot find any way to disable it. Anybody have any clue where it might be? I looked in ssh and everything is perfectly intact, it is just WHM.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    From my investigations, the clustering works through this path on the server:

    /var/cpanel/cluster/root/config/

    To get rid of it, you can delete all dirs and files from and including:

    /var/cpanel/cluster

    I had to do this once after DNS clustering got screwed up on a server, but this may have nothing to do with your problem.
     
  3. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    Thanks for the reply, that entire directory was empty so I deleted (well rather moved) it. There was also a clusterqueue which I deleted.

    Anybody have any other ideas?
     
  4. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    Thanks to bdraco I was able to find out the problem. In the edit setup there is a "Master Nameserver" option and there was an ip listed. Remove the ip and everything starts working again :)
     
Loading...

Share This Page