The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Edit Package Bug?

Discussion in 'General Discussion' started by ckh, May 27, 2009.

  1. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    I have a couple packages that I wanted to edit to change the dedicated IP option from no to yes.

    However, when I edit the package, where the check box normally is to allow you to change it, it simply has a 'no' there and you can't change the option.

    The only solution is delete the package and recreate it.

    Was this by design or is this a bug?

    running cPanel 11.24.4-R36167 - WHM 11.24.2 - X 3.9
    REDHAT Enterprise 5.3 i686 standard
     
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    Please check in Reseller center -> select reseller account name -> Make sure Allow Creation of Packages with a Dedicated IP is selected.
     
  3. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    It's not a reseller account and it's the same way on 4 of my servers.

    I can create the package and check the option to assign an ip address.

    However, if I want to edit a package and change the option, you can't.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    This is by design.

    Modifying a package causes all accounts assigned the package to be updated with the new settings. To prevent issues, we disallow modifying the Dedicated IP parameter.
     
  5. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    Thanks for the info, Kenneth. I can see where that could cause a problem then. I just modified the package via ssh and that worked fine.
     
Loading...

Share This Page