Wildorchid

Registered
Mar 5, 2004
4
0
151
Hi,

As a reseller on a Cpanel server I can add and edit packages. Each time I edit a package ssh access to the accounts using this package breaks.

When I open the edit package form the ssh box is always unchecked even if ssh was turned on before. No matter if I check or leave it unchecked, after updating the package ssh is removed for the accounts using this particular package.

Is this a bug or missconfiguration somewhere?

WHM 8.8.0 cPanel 8.8.0-S74
RedHat 7.3 - WHM X v2.1.2

Thanks for your help.
 

Wildorchid

Registered
Mar 5, 2004
4
0
151
Hi,

My host says he thinks that the ssh option is turned on for resellers. He wants to make sure and would like to know from you where exactly this option needs to be turned on ;)

Thanks for your help.
 

ddeans

Well-Known Member
Feb 13, 2004
296
0
166
Maryland
Originally Posted by Wildorchild
My host says he thinks that the ssh option is turned on for resellers. He wants to make sure and would like to know from you where exactly this option needs to be turned on
If he doesn't know how to turn it on, he's in the wrong business.

Setup -> Reseller Center -> Modify Privileges -> Then check the allow to give ssh access box.
 

Wildorchid

Registered
Mar 5, 2004
4
0
151
Hi ddeans,

First of all thanks for your reply. Second please do not say something like this in a public support forum. My host has just launched this new server with Cpanel and his other servers were all hand tailored without Cpanel so it is all new for him too.

My point of view is that as a reseller I appreciate that he is moving forward to new technology platform and if there are problems I will try to help solving them asap.

So back to this problem. He has double checked and swears that this is turned on but it still doesn't work.

As soon as I modify any of my packages I loose ssh again on all the accounts that us this package.

Any other suggestion where the problem can be.

Thanks for your help.
 

vishwas

Well-Known Member
Feb 9, 2004
61
0
156
Front of PC
Hello ddeans,

I had a same problem as Wildorchid mentioned there was one option in root whm check this block and my issue get resolved

Setup -> Reseller Center -> Modify Privileges ->
[ ] Never allow creation of accounts with shell access

Thanks ddeans

:D