Elevate errors converting from CentOS7 to Rocky

sp3ctre69

Well-Known Member
Aug 14, 2006
111
5
168
I just upgraded one of my DNSOnly boxes from CentOS to Rocky. Along the way I got the following error:

can't use an undefined value as a HASH reference.... and then a line number. I couldn't find any info about it so I went to the line number and just added a "return;" at the start of the function. It was (if I remember correctly) the function to re-install Immunify. It also did it on quite a few other lines (Litespeed check was one).

All appears to be working now but I am a bit nervous to upgrade my other boxes without knowing what these errors were about or how to correct them.
 

sp3ctre69

Well-Known Member
Aug 14, 2006
111
5
168
Hey there! I'm not sure that gives me enough to go on to help with the issue, but if you can consistently recreate the problem could you submit a ticket to our team so we can check it out?
One of the examples was referencing this line:

my $data = read_stage_file('reinstall')->{'jetbackup'};

Each time the error happened it was a similar line to this one.

Another example:

return unless read_stage_file('reinstall')->{'influxdb'};
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
13,329
2,102
363
cPanel Access Level
Root Administrator
Thanks for that - I have let our developers know, but it's unlikely I'm going to hear back for a few days about this due to the holiday weekend. The ELevate tools are also still experimental, so it's possible this is just something that hasn't been resolved yet. If I hear back with more details, I'll be sure to post a reply!
 

sp3ctre69

Well-Known Member
Aug 14, 2006
111
5
168
Thanks for that - I have let our developers know, but it's unlikely I'm going to hear back for a few days about this due to the holiday weekend. The ELevate tools are also still experimental, so it's possible this is just something that hasn't been resolved yet. If I hear back with more details, I'll be sure to post a reply!
Nice one... I can dig out more examples if required, but I think they all have similar code in them. Hopefully something simple... was just keen to get on with the conversion as I'd forgotten to snapshot the VM first so didn't pay too much attention.
 

sp3ctre69

Well-Known Member
Aug 14, 2006
111
5
168
Just to add, I found someone else with a similar issue:


Interesting that his issue was also a DNSOnly instance... could be a coincidence but thought it was worth mentioning.