The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

email accepted for an account which doesn't exist

Discussion in 'E-mail Discussions' started by keat63, May 1, 2015.

  1. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    If I run a mail delivery report against an account which doesn't exist, i'm seeing some odd results.
    I'm seeing failure entries (which i'd expect), but also some accept entries.
    If the mailbox doesn't exist, how can they be accepted.
    Also looking at exim mainlog, it appears that this mailbox has performed an auto respond, but there is no auto respond.
    Code:
    2015-05-01 12:56:22 cwd=/etc/csf 2 args: /usr/sbin/exim -bpc
    
    
    2015-05-01 12:56:56 SMTP connection from [xxx.xxx.126.48]:51140 (TCP/IP connection count = 1)
    
    
    2015-05-01 12:56:56 no host name found for IP address xxx.xxx.126.48
    
    
    2015-05-01 12:56:57 H=([xxx.xxx.126.48]) [xxx.xxx.126.48]:51140 Warning: Sender rate 1.0 / 1h
    
    
    2015-05-01 12:56:59 1Yo9Yw-00052y-6x H=([xxx.xxx.126.48]) [xxx.xxx.126.48]:51140 Warning: Message has been scanned: no virus or other harmful content was found
    
    
    2015-05-01 12:57:00 1Yo9Yw-00052y-6x H=([xxx.xxx.126.48]) [xxx.xxx.126.48]:51140 Warning: "SpamAssassin as xxx detected message as spam (5.1)"
    
    
    2015-05-01 12:57:00 1Yo9Yw-00052y-6x H=([xxx.xxx.126.48]) [xxx.xxx.126.48]:51140 Warning: "Increment Connection Ratelimit - ([xxx.xxx.126.48]) [xxx.xxx.126.48]:51140 because mail server detected a message with a spam score integer greater or equal to 40"
    
    
    2015-05-01 12:57:01 1Yo9Yw-00052y-6x <= Imelda.a41@kandia.ro H=([xxx.xxx.126.48]) [xxx.xxx.126.48]:51140 P=esmtp S=46121 id=F658FD93BBE81AE_A912_93607@webmail-va101.sysops.aol.com T="Copy of claim passed for consideration to HM Courts Ref:[KE8845RTT] from DOWNING PLANNED EXIT VCT 7 " for jayne@mydomain.com
    
    
    2015-05-01 12:57:01 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1Yo9Yw-00052y-6x
    
    
    2015-05-01 12:57:01 SMTP connection from ([xxx.xxx.126.48]) [xxx.xxx.126.48]:51140 closed by QUIT
    
    
    2015-05-01 12:57:01 1Yo9Yw-00052y-6x => |/usr/local/cpanel/bin/autorespond jayne@mydomain.com /home/mydom/.autorespond (jayne@mydomain.com) <jayne@mydomain.com> R=virtual_aliases_nostar T=jailed_virtual_address_pipe
    
    
    2015-05-01 12:57:01 1Yo9Yw-00052y-6x Completed
    
    
    i'm perplexed
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    What do you have configured under "Default Address" for the domain names added to this account? Also, does /home/mydom/.autorespond exist, and if so, is it populated?

    Thank you.
     
  3. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I do have an autorespond folder under home/mydom, with a few autorespond rules in there, but nothing for this user account.
    The default address is set to discard, with a failure message.
    Maybe this was the auto respond ?
     
  4. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Actually, looking at the delivery event details, something doesn't add up.

    Recipient: jayne@mydom.co.uk (doesn't exist)
    Delivered To: |/usr/local/cpanel/bin/autorespond jayne@mydom.co.uk /home/*******/.autorespond
    deliveryuser: CPanel Acc
    deliverydomain: mydom.co.uk

    Under the Delivered To: ******* doesn't exist as a user, this was originally a test account.

    Just to see what happens, I've recreated the email account and an auto responder, and deleted them both.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I've not seen an instance where previously deleted autoresponders still function, but feel free to let us know the outcome.

    Thank you.
     
  6. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Having checked this morning, i can see that all messages sent to the non existent account have bounced, so it's looking better.
    A few days will tell i guess.
     
Loading...

Share This Page