The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email accont access issue on all acconts after the upgrade.

Discussion in 'E-mail Discussions' started by jols, Nov 9, 2010.

  1. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    This was likely due to the recent cPanel update.

    Accessing any account, via WHM or direct cPanel login.

    Click Email Accounts, and a popup box is then displayed with this error:
    -----------------
    You need to pass the title of the validator object into the constructor.
    ie: var my_validator = new CPANEL.validate.validator("Email Account");
    -----------------

    Any further email account operations can not be made. Although the actual email sending and receiving still works (I think).
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    What version of cPanel are you running? I'm running CURRENT here on the server I just tested this on and am not seeing the behavior you describe here.
     
  3. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    RELEASE:

    WHM 11.28.27
    REDHAT Enterprise 5.5 i686 standard
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,446
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might want to put in a ticket on this rather than waiting on community forum support.
     
  5. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    I have, about an hour ago, thanks. So far no response.
     
  6. mainecrab

    mainecrab Registered

    Joined:
    Jul 12, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    On my box the issue was with SpamAssassin. There was a failure in importing the GPG key when running sa-update. I did the following:

    wget http://spamassassin.apache.org/updates/GPG.KEY
    /usr/bin/sa-update --import GPG.KEY
    /usr/bin/sa-update

    After which Exim would restart normally and not give the long page of errors.
     
  7. jols

    jols Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,111
    Likes Received:
    2
    Trophy Points:
    38
    This has been resolved. We had an immutable bit on one of the cPanel files that needed updating. This stemmed from the critical issue (for us) of not being able to control the default email quotas in cPanel, which happily, is now configurable via the new WHM.
     
Loading...

Share This Page