The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email accounts not showing after transfer

Discussion in 'E-mail Discussions' started by bbunlock, May 31, 2012.

  1. bbunlock

    bbunlock Member

    Joined:
    Jan 3, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Hi I have just transfered over accounts from 1 server to a new server, managed to get the accounts all sent over however when loging into cpanel and going to email accounts there are no accounts listed (and there should be)

    I have checked the contents of the /home/user/ folder and all files have been transfered including mail and etc but they email accounts just do not show in cpanel?

    can anyone suggest a way to solve this please

    regards

    wayne
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Wayne,

    Could you try running "/scripts/mailperm" and wait for it to process, then see the results? Sometimes, it could be due to incorrect file permissions on the /home/username/etc or /home/username/mail folders.

    Thanks!
     
  3. bbunlock

    bbunlock Member

    Joined:
    Jan 3, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ran the script /scripts/mailperm from root (as root) and it was done instantly, however I still have no email addresses showing in cpanel, I have even done a rsync between the /home dir from old to ne server, so everything that was in the /home/username/ folders is now on the ne server but still no email accounts show up in cpanel?

    any other sugestions ould be appriciated, I have another 3 days to solve this before the old server is taken down

    regards

    wayne
     
  4. bbunlock

    bbunlock Member

    Joined:
    Jan 3, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    please does anyone know hy email accounts are not showing in cpanel after using transfers in whm

    My old server will be taken offline on 5th of this month so I have until then to find out and fix why the emails dont show up for accounts in cpanel

    regards

    wayne
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Wayne,

    Please submit a ticket for us to investigate. The forums are not emergency support and we cannot log into the machine directly here to troubleshoot. Tickets can be submitted for no cost if you have a valid cPanel license. Please use either the link in my signature or WHM > Support Center > Contact cPanel.

    Please post the ticket number here after submitting one.

    Thanks!
     
  6. bbunlock

    bbunlock Member

    Joined:
    Jan 3, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply, I have oened a ticket for help in this, here is the ticket id is 2753242

    regards

    wayne
     
  7. bbunlock

    bbunlock Member

    Joined:
    Jan 3, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    ok found the resolution and thought I would share it here in case others have similar problems.

    As this was a new server the accounts were transfering to it had not been setup completly, I had not configured apache or php or anything else, I transfered the accounts first onto a brand new server and that was the problem.

    I decided to finish the setup of the server yesterday so went through the easyapache process, after I set this new server up with the same (vary similar) settings as the old server all the email accounts were working fine.

    I think the problem was with not having mod_security setup on the new server as I was seeing errors regarding this in the transfer logs.

    So my advice get the destination server setup in a similar way to the old server and then do the transffers and everything should be fine.

    hope this helps someone

    regards

    wayne
     
  8. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    strange one :) how we can relate the email account listing missing in cPanel with the easyapache ? . Is there anything like that ?, or did you done anything else? Like complete the WHM initial configuration after cPanel installation. Glad to here your issue fixed....
     
Loading...

Share This Page