The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

email accounts vanished

Discussion in 'E-mail Discussions' started by lifeisboost, Jul 16, 2005.

  1. lifeisboost

    lifeisboost Member

    Joined:
    Mar 7, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    OKay today i tired ot check my email on one of my domains. and low and behold the accounts dissapeard. i logged into cpanel and they are gone. i cant even create an email account. it says it is created but when you go back to the webmail admin the accounts are not listed. I checked the domian through ftp and the accounts are listed under mail..... this is the only domain this has happend on. all other domains the emails are working correctly. i tried a couple solutions i found but none of them helped. anyone have some insight? I also tried a daily backup but it did not fix the problem
     
  2. nickb

    nickb Well-Known Member

    Joined:
    Feb 25, 2005
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    check /home/username/etc/passwd and shadow files and make sure they have proper entries for all of your mail accounts. Check the permissions and ownerships on mail boxes as well.
     
  3. lifeisboost

    lifeisboost Member

    Joined:
    Mar 7, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    they ae all correct. the emails work fine if you log into www.domain/webmail or try to access them from outlook. they are just unlinked from Cpanel.
     
  4. deadsoulz

    deadsoulz Member

    Joined:
    Mar 2, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Did you ever figure this one out? I am having hte same problem with a customer.

     
  5. lifeisboost

    lifeisboost Member

    Joined:
    Mar 7, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Actually i found our drive was going bad and was destroying files. we replaced the drive then restored a backup and had to set the email accounts back up but they work fine now. not sure if that is your problem but ours is fixed....
     
  6. jorj1

    jorj1 Member

    Joined:
    Nov 21, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Just had this problem and found that there was a file named /home/username/etc/_domainname.com* where it should've been a folder with that name. As a result any try to create emails under that domain failed. The solution was to delete that file and create the folder with that name.
    ..but don't ask how was that file created and why did it contain HTML content regarding to Samba.
     
Loading...

Share This Page