Email and FTP broken after notification of free cPanel-signed hostname SSL certificate installation

swbrains

Well-Known Member
Sep 13, 2006
202
27
178
I received an email tonight: "Your free cPanel-signed hostname SSL certificate for..." indicating a new server hostname certificate had been issued/installed (example: hostname.myserver.com).

Shortly after that, logging into my POP account for my primary account on that server (ex: myserver.com) in Thunderbird issues a message that the SSL certificate for that domain no longer matches the certificate. The cert it shows is for "hostname.myserver.com" even though my email app logs into the POP account using server "myserver.com" (Port 995) and always has.

I tried FileZilla and found that logging into any hosted account (subdomain or domain) on my server issues a message: "hostname does not match certificate". In this case, the hosted account for example would be "hosteddomain.com" but the error message indicates the SSL certificate common name is "hostname.myserver.com".

How do I get Thunderbird to be able to log in to my main domain's account using SSL/port 995 without this error message. It allows me to accept an exception, but it seems like this would be bad as it shouldn't be an exception. The domain's account has it's own valid SSL cert that Thunderbird and FileZilla should use, but they don't seem to be seeing it.

Thanks for any advice anyone can provide...
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
HI @swbrains

What's set as the SSL settings in Manual when you go to cPanel>>Email>>Email Accounts -> Connect Devices (Next to the email account you are experiencing the issue with)


What is also set in WHM>>Server Configuration>>Tweak Settings for the following:

  • Choose the closest matched domain for which that the system has a valid certificate when redirecting from non-SSL to SSL URLs. Formerly known as “Always redirect to SSL/TLS”
  • Require SSL for cPanel Services
 

swbrains

Well-Known Member
Sep 13, 2006
202
27
178
Thanks @cPanelLauren for your reply. Here's what I found...

In the account's cPanel email settings, the Manual settings show:

User = [email protected][mydomain]

but in TB I simply use the user ID of the primary email account, not an email address format which has worked (and still works other than the SSL message).

It also says to use "mail.[mydomain]" as the incoming/outgoing server names but in TB I am using just [mydomain].

In WHM Tweak Settings,

Choose the closest matched domain... is set to OFF
Require SSL for cPanel Services is set to OFF