Email can be received but not send

Timile

Member
Aug 17, 2021
7
0
1
Canada
cPanel Access Level
Root Administrator
Hi,

I'm trying to fix a problem who recently appear (4 days) and is reaching all accounts on my WHM server.

All accounts can receive email but cannot send. Problem is simple but cannot find a solution.

Classic configuration WHM with Exim as mail server.

What I've tried:
- reboot email server, use email troubleshooting, email Email Deliverability tool. All tool are looking good, they are all saying all is good.
- Checking my firewall config, testing connection with mail server : Gmail on port 25 : ok, Yahoo on port 25 : ok, icloud on port 25 : ok.
- Try to force delivering an email but connection always timeout after 5m.

Here's my log when I try to send email:
LOG: MAIN
cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1mQCXG-0001Mv-Og
delivering 1mQCXG-0001Mv-Og
LOG: MAIN
Sender identification U=leam D=**********.com [email protected]******.com
Connecting to mx02.mail.icloud.com [17.57.154.7]:25 ... failed: Connection timed out (timeout=5m)
LOG: MAIN
H=mx02.mail.icloud.com [17.57.154.7] Connection timed out

Can someone have idea how I can repair this? Thank you.
 

Timile

Member
Aug 17, 2021
7
0
1
Canada
cPanel Access Level
Root Administrator
Hi!

I've run the commands and here's the output:

curl portquiz.net:25
220-hostname.hostname.com ESMTP Exim 4.94.2 #2 Tue, 14 Sep 2021 15:08:27 -0400
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
500 unrecognized command
500 unrecognized command
500 unrecognized command
500 Too many unrecognized commands

And:
traceroute to smtp.gmail.com (209.85.144.109), 30 hops max, 60 byte packets
1 * * *
2 * * *
3 * * *
4 * * *
5 * * * 6 * * * 7 * * * 8 * * * 9 * * *10 * * *11 * * *12 * * *13 * * *14 * * *15 * * *16 * * *17 * * *18 * * *19 * * *20 * * *21 * * *22 * * *23 * * *24 * * *25 * * *26 * * *27 * * *28 * * *29 * * *30 * * *

Waiting for your answer, thank you!
 

Timile

Member
Aug 17, 2021
7
0
1
Canada
cPanel Access Level
Root Administrator
Hi,

I've disabled SMTP restrictions, reboot and still cannot send email. I've retry to run the two commands and here the new results:

curl portquiz.net:25
curl: (7) Failed connect to portquiz.net:25; Connection timed out

And:

traceroute -p 25 smtp.gmail.com
traceroute to smtp.gmail.com (173.194.68.108), 30 hops max, 60 byte packets
1 * * *
2 * * *
3 * * *
4 * * *
5 * * *
6 *00 * *
7 * * *
8 * * * 9 * * *10 * * *11 * * *12 * * *13 * * *14 * * *15 * * *16 * * *17 * * *18 * * *19 * * *20 * * *21 * * *22 * * *23 * * *24 * * *25 * * *26 * * *27 * * *28 * * *29 * * *30 * * *
 

cPJustinD

Administrator
Staff member
Jan 12, 2021
285
45
103
Houston
cPanel Access Level
Root Administrator
Thank you for that output. As the SMTP restrictions are disabled, and the outbound connections are still timing out, it appears the restriction is coming from a local or network firewall.

You will need to work with your server administrator or hosting provider for further assistance in determining why the port is restricted and taking the appropriate measures to ensure that it is open for outbound requests. We've also published an article that covers this topic here:

Why can I receive, but not send, emails?
 
Last edited: