Email Client cannot connect to IMAP using SSL\TLS (port 993)

JessC

Member
Oct 3, 2019
12
2
3
Philippines
cPanel Access Level
Reseller Owner
Hi All,

I'm having issue with our email clients. For some reason it can't connect to the email server using secured IMAP connection (SSL\TLS). It was working until recently when our users starts complaining that they're not receiving emails.

When I troubleshoot from the our email client, it can't connect using SSL\TLS connection but STARTTLS (port 143) works.
I also tried running the command from cmd "telnet domainname 993". It can't connect but "telnet domainname 143" works fine.

I contacted GoDaddy which is our provider and this is what I get.

"regards to our Hosting Team though, under Shared, by default, it shouldn't be working, so what
they're saying is they can't troubleshoot it if it's something that shouldn't work in the first place. the work around
that they gave is to check with cPanel forum instead on how to go about it using the SSL that you have ."

Please advice.

Thank you very much
 
  • Like
Reactions: prettyjarin786

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,272
313
Houston
To understand correctly, they're telling you that you should not be able to connect over a secure port from their shared servers? That doesn't make a whole lot of sense, I'm not sure I understand why their mailserver wouldn't support encryption.

Do you have an SSL certificate installed for the domain you're configuring mail for? If you don't you'd need one to configure the mail client for TLS.
 

JessC

Member
Oct 3, 2019
12
2
3
Philippines
cPanel Access Level
Reseller Owner
To understand correctly, they're telling you that you should not be able to connect over a secure port from their shared servers? That doesn't make a whole lot of sense, I'm not sure I understand why their mailserver wouldn't support encryption.

Do you have an SSL certificate installed for the domain you're configuring mail for? If you don't you'd need one to configure the mail client for TLS.
Hi Sir,
Yes, I installed an SSL certificate and after a couple of days, I was able to set up our mail client using SSL\TLS encryption. For some reason, it stops working and I contacted them and they're saying that it shouldn't really work by default. The option is just to use nonSSL settings

I mentioned it was working previously and they said that some servers "may" work in 993 but by default it should not.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,272
313
Houston
If that's the truth which I think you should verify by contacting them again, there's nothing I can do to assist you. If you're on a shared server you can't open ports so you'd be at the mercy of your provider. If encrypted email is something you need (which most people do) I'd suggest finding another provider.
 

TejasM

Member
May 4, 2020
8
1
3
India
cPanel Access Level
Website Owner
Hi JessC,
I have a similar problem with GoDaddy. The SMTP over SSL/TLS have stopped working suddenly while when we try from port 143 it works but its unsecured.
Godaddys support team is pathetic and non responsive. They want to upgrade us to dedicated mail and wont support on C Panel emails.

I faced the same issue around 10-12 days back, complained to Godaddy but to no help. Then after a downtime of 4 days it started working properly automatically !!
Now again we have the same issue.
 
  • Like
Reactions: JessC

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,272
313
Houston
If your provider is indicating that this shouldn't be functioning by default, I'd lean toward their limiting its availability to you. You could try to contact them again to identify why exactly you don't have this access but you had it previously. Unfortunately, we have no control over the configuration of these servers so the best I can tell you is to contact them and find out their rules for email on these servers and base your decision moving forward on your needs. We're here to help if you need anything at all that is within our ability to assist with.
 

TejasM

Member
May 4, 2020
8
1
3
India
cPanel Access Level
Website Owner
I have the same problem. They charge us and show all the features while selling. But now they go back on their words. Somebody should sue them.
Pathetic support levels of Godaddy
 

TylerDurden

Registered
Dec 14, 2020
1
0
1
Houston
cPanel Access Level
Website Owner
If that's the truth which I think you should verify by contacting them again, there's nothing I can do to assist you. If you're on a shared server you can't open ports so you'd be at the mercy of your provider. If encrypted email is something you need (which most people do) I'd suggest finding another provider.
I am now having the same situation. I did notice that the date this stopped working was the date my self signed SSL certs were renewed on the server. I did not make this update. I don't know if it is automatic? I tried creating new self signed certs and applying them to all the subdomains but that didn't help. But it seems like something broke when the certs got renewed.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
6,951
921
313
cPanel Access Level
Root Administrator
@TylerDurden - since you don't have root access to the system you may need to speak with your hosting provider or datacenter to see exactly what changed and have them investigate that. Self-signed certs do also get automatically renewed if a valid certificate can't be issued by AutoSSL, so that could be part of what is happening here.