The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Client Details Display Wrong Port Number

Discussion in 'E-mail Discussions' started by zuronam, Feb 2, 2017.

  1. zuronam

    zuronam Member

    Joined:
    Aug 2, 2016
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Zimbabwe
    cPanel Access Level:
    Root Administrator
    Hi All,

    I have two cpanel servers that have this setting displaying port 26,
    correct.png
    and two displaying port 25

    incorrect.png
    My question is - on the server's diplaying port 25 - what do I need to go and change in WHM config to display port 26?

    I've looked at
    Tweak settings
    Exim Configuration
    Service Manager (port 26 specification)
    CSF / LFD ports

    and nothing seems to make a change

    Any help would be most appreciated.

    Kind Regards
    @zuronam
     
    #1 zuronam, Feb 2, 2017
    Last edited: Feb 2, 2017
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,618
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    WebHost Manager »Service Configuration »Service Manager, Exim Mail Server (on another port)

    HTH! :)
     
  3. zuronam

    zuronam Member

    Joined:
    Aug 2, 2016
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Zimbabwe
    cPanel Access Level:
    Root Administrator
    Thanks for the reply Infopro

    This is already setup on my servers -it is uniform across the board

    already set that.png

    My issue is that - when a client logs in to their Cpanel account and goes to Mail Client Configuration - they are greeted with port 26 for the Non-SSl settings - vs the port 25 that is showing on my servers currently (as per attachments in 1st post)

    Regards
    @zuronam
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,618
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    My apologies, I didn't take a moment to look at my own servers. I just did now and see the same thing.
     
  5. sktest123

    sktest123 Well-Known Member

    Joined:
    Jan 31, 2017
    Messages:
    69
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    kochin
    cPanel Access Level:
    Root Administrator
    vi /usr/local/cpanel/base/frontend/paper_lantern/mail/clientconf_manual_settings_include.html.tt

    then change this line as follows

    <li [% IF in_html_email; li_props; END %]>[% locale.maketext("[output,abbr,SMTP,Simple Mail Transfer Protocol] Port: [_1]",26) %]</li>


    restart cpanel service :)

    PS:please do backup and do at your own risk , any way it's working
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,618
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    That's not a proper fix for this matter.
     
  7. sktest123

    sktest123 Well-Known Member

    Joined:
    Jan 31, 2017
    Messages:
    69
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    kochin
    cPanel Access Level:
    Root Administrator
    Yes the update will revert back the settings . adding the said file to /etc/cpanelsync.exclude will retain the settings , but yes it's not a better fix at all.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,287
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Internal case CPANEL-10490 is open to address an issue where upon enabling an additional port for Exim via "WHM >> Service Manager", only the lowest port number is reported in "cPanel >> Email >> Email Accounts >> Set Up Mail Client" under "Mail Client Manual Settings". Thus, if you enabled Exim to run on port 24, it would correctly show up in the UI, however if you enabled port 26, then port 25 would show up because it's the lower number. I'll update this thread with more information on the status of this case as it becomes available.

    Thank you.
     
    Infopro likes this.
  9. zuronam

    zuronam Member

    Joined:
    Aug 2, 2016
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Zimbabwe
    cPanel Access Level:
    Root Administrator
    Thank you CpanelMichael - that makes so much sense as the 4 servers I am running are exact clones in terms of WHM configuration, and that's why it was doing my head in that the two that updated to 62.0 build 7 have this displaying port 25 problem, whereas the ones still on 60.0 build 35 do not exhibit this.
     
    cPanelMichael likes this.
  10. ethical

    ethical Well-Known Member

    Joined:
    Apr 7, 2009
    Messages:
    83
    Likes Received:
    2
    Trophy Points:
    58
    To add a bit to this discussion, i use ASSP and therefore they require us to turn turn OFF the alternative port because ASSP will run the alternative port(s) . so I cant set this in my server to show port 26 and port 25 i dont know any ISP that actually allows connections on on port 25 anymore, its totally obsolete. Instead of fixing this case, why not actually just allow all this info to be edit by the server admin. I dont want to actually show ANY non ssl settings. (similar to this request although i've added in an extra request to make it fully editable.
    Ability to customise the "Mail Client Configuration" page in cPanel
     
Loading...

Share This Page