Email delivery configuration

bytron

Registered
Jun 27, 2006
4
0
151
Currently our configuration of cpanel behaves slightly odd in regards to email delivery. I'm sure its a configuration issue, but after trawling around the Forums, GUI and command line I cannot find anything that matches my problem.

The problem is when a email is recieved that is addressed for a inbox that is over quota all mail message get stuck in the queue. This includes message destine for other users. The queue does not clear until either I remove the email or the user who's inbox is full cleans out ant old emails.
 

ramprage

Well-Known Member
Jul 21, 2002
655
0
166
Canada
This is normal and the default setting on most servers, full mailboxes cannot take more mail so the server holds it in the main queue until the mailbox is available.

There's an option in Tweak Settings to discard mail for full mailboxes instead of storing it in the mail queue.
 

bytron

Registered
Jun 27, 2006
4
0
151
Thanks for the response. I understand that its default behavoiur to hold message in the queue for a user that is over quota. I have no objections as this is logical.

What I observe is that other emails destine for other users, who have plenty of quota get queued behind the offending email.

For example say [email protected] exceedes his quota, then a new message arrives for bob. This message sits in the queue reporting bob is over quota (logical).
Then another new message arrives for [email protected]. The queue then shows both emails. The second email does not get delivered until either the first email is deleted or the offending user clean up their mailbox. Not logical.
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,465
30
473
Go on, have a guess
That should not happen as the queue manager for exim doesn't work that way. It processes 5 emails per child IIRC, as it goes through the queue. Any email that cannot be delivered is requeued and it then moves on to process the next one. If the email isn't queued, then it gets delivered immediately anyway.