Email Does Not Working After Transferring Between WHM Servers

Steve Kessler

Active Member
Feb 22, 2015
27
0
1
Denver, Colorado, United State
cPanel Access Level
Root Administrator
I have email configured and working on one WHM server. The only thing I host on WHM at this time is the email. I used the WHM transfer tool to bring the email over to my new WHM server. Now I get "This message was created automatically by mail delivery software. A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:"

Any idea why this is happening? The transfer said it came over correctly and the accounts are listing in cPanel.

Thanks,
Steve
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Hello,

Try reviewing /var/log/exim_mainlog or /var/log/exim_rejectlog to get a better idea of why the messages fail. You can search for a specific email address with a command such as:

Code:
exigrep [email protected] /var/log/exim_mainlog
Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
To update, it looks like adding the hostname to the /etc/localdomains file addressed the issue.

Thank you.
 

ruzbehraja

Well-Known Member
May 19, 2011
392
11
68
cPanel Access Level
Root Administrator
Now I get "This message was created automatically by mail delivery software. A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:"
What is the full error message?

In the Edit DNS options have you set the option:

- Local Mail Exchanger