The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email: failed to read delivery status

Discussion in 'E-mail Discussions' started by kosmo, Mar 1, 2002.

  1. kosmo

    kosmo Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    403
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    All over Europe
    Hi,

    any clue what happens here? All email addresses of one particular domain can't be delivered. I had a look at exim_mainlog and it looks like this:

    2002-03-01 05:21:07 16gmyB-0004Sc-00 &= support@mydomain.com H=my.dialin.net ([x.x.x.x]) [y.y.y.y] P=esmtp S=534 id=B8A53EC5.4088%support@mydomain.com
    2002-03-01 05:21:07 16gmyB-0004Sc-00 failed to read delivery status for \info@clientsdomain.com from delivery subprocess
    2002-03-01 05:21:07 16gmyB-0004Sc-00 pipe transport process returned non-zero status 0x000b: terminated by signal 11
    2002-03-01 05:21:07 16gmyB-0004Sc-00 == info@clientsdomain.com &info@clientsdomain.com& T=virtual_sa_userdelivery defer (-1)
    2002-03-01 05:21:07 16gmyB-0004Si-00 &= username@myserver U=username P=local S=838
    2002-03-01 05:21:07 16gmyB-0004Sc-00 =& |/usr/local/cpanel/bin/autorespond info@clientsdomain.com /home/ecoprint/.autorespond (info@clientsdomain.com) &info@clientsdomain.com& D=virtual_aliases_nostar T=virtual_address_pipe
    2002-03-01 05:21:07 16gmyB-0004Sc-00 Frozen
    2002-03-01 05:21:07 16gmyB-0004Si-00 =& mylogin &support@mydomain.com& D=localuser T=local_delivery
    2002-03-01 05:21:07 16gmyB-0004Si-00 Completed

    This happens no matter if the email addresses are real or not. Any idea? Valiases, localdomains, userdomains look pretty normal.

    kosmo
     
  2. kosmo

    kosmo Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    403
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    All over Europe
    OK, the client had enabled spam-assassin. Disabled it and mail works again. When will it be removed from CP?

    kosmo
     
  3. Jemshi

    Jemshi Well-Known Member

    Joined:
    Sep 11, 2003
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    we have the same problem on an Enterprise machine. Mails get delivered to domains like yahoo, hotmail etc but not all others.

    Lot of them fails with 0x000b status.

    R=lookuphost T=remote_smtp defer (-1): smtp transport process returned non-zero status 0x000b: terminated by signal 11

    Lot of addresses are generating this error.

    Exim in debug mode shows this.

    07:27:20 3419 Calling SSL_connect
    07:27:20 3419 SSL_connect succeeded
    07:27:20 3418 reading pipe for subprocess 3419 (not ended)
    07:27:20 3418 read() yielded 0
    07:27:20 3418 remote delivery process 3419 ended: status=000b
    07:27:20 3418 set_process_info: 3418 delivering 1AuAc4-0000qg-ST
    07:27:20 3418 ---0 Get 0x816cef8 80 string.c 349
    07:27:20 3418 post-process address@remotedomain (1)
    07:27:20 3418 ---0 Get 0x816cf48 64 string.c 1228
    07:27:20 3418 ---0 Get 0x816cf88 256 deliver.c 957
    07:27:20 3418 LOG: MAIN
    07:27:20 3418 == address@remotedomain R=lookuphost T=remote_smtp defer (-1): smtp transport process returned non-zero status 0x000b: terminated by signal 11
    07:27:20 3418 ---0 Rst 0x816cf88 ** deliver.c 1000 51648

    Only the relevant portion is pasted. Anyone else having this problem ?
     
  4. Jemshi

    Jemshi Well-Known Member

    Joined:
    Sep 11, 2003
    Messages:
    210
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Juz posted a trouble ticket for the same.

    cPanel.net Support Ticket Number: 40090
     
  5. yufool

    yufool Active Member

    Joined:
    Jan 24, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    yes

    This is driving me completely nuts.

    Yes, this is the exact problem I was having. I'm thinking it is my reverse DNS lookups but DNSreports and DNsstuff is coming back fine.

    inspired@marylynha.com R=lookuphost T=remote_smtp defer (-1): smtp $
    2004-02-23 17:11:21 1AvNf2-00041w-G4 Frozen

    mail.dreampod.com shouldn't be having any problems....If anyone finds anything let us know.
     
  6. jcaliaga

    jcaliaga Member

    Joined:
    Nov 7, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Same Thing

    I have problem whith hotmail , nobody can sent mails with attached files to any email account hosted in the server.
    I HAVE THIS PROBLEM FOR ALMOST 4 MONTHs, i already sent 3 Tickets and the Cpanel Support Team never get back to me with a Solution :mad:

    Maybe some user have the same problem.

    Thanks in advance

    JC
     
  7. Remon

    Remon Member

    Joined:
    Jan 31, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    How did you guys solve this error?

    I get the error too:
     
  8. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    As much as I hate to resurrect an old thread, I am having a very similar problem to this right now one one of our cpanel servers. The error is as follows when trying to send an email stuck in the queue...

    The exim_mainlog shows this error...

    How was this resolved before as no one really posted back?
     
    #8 HollyRidge, Jun 14, 2007
    Last edited: Jun 14, 2007
  9. root1

    root1 Registered

    Joined:
    Sep 10, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Yes, I just started seeing these on one of my five CPanel boxes... the only one running current, just started around 3:00am tonight following some exim.conf not found complaints... Oh Cpanel, what have you done now :P
     
  10. noorolhoda

    noorolhoda Active Member

    Joined:
    Jul 19, 2004
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
  11. Cristian99

    Cristian99 Active Member

    Joined:
    Jun 17, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    NO SOLUTION?
    CPANEL TECH are you here?
     
  12. mooony

    mooony Well-Known Member

    Joined:
    Nov 9, 2002
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    6
    I had the same problem this morning. You need to upgrade the servers to maildir to resolve this problem.

    Ronald
     
  13. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    yes - updating to maildir fixed it for us too :)

    nice one
     
  14. ramiel

    ramiel Member

    Joined:
    Mar 14, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mountain View, CA, USA
    How do you update to maildir?

    I just started having this problem only with one customer too. Very strange.

    How do you update to use maildir? I'm familiar with maildir, just don't know how to change that in cPanel.

    Need to fix immediately, this is emergency issue as customer's emails aren't working.

    - Ramiel

     
  15. ramiel

    ramiel Member

    Joined:
    Mar 14, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mountain View, CA, USA
    haha answering myself


    @!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@
    @! ATTENTION! mbox is deprecated in this release !@
    @!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@
    @ You should switch to using maildir as soon as @
    @ possible. To switch run @
    @ /scripts/convert2maildir @
    @ in a root shell. @
    @!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@
     
  16. swapneel

    swapneel Member

    Joined:
    Oct 2, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I'm facing this problem with one of our servers. The server is currently using mbox. Is there any other go other than converting to maildir ?

    Also if we had to convert the server to use maildir, apart from running the script convert2maildir I would have to change maildir=1 in /var/cpanel/cpanel.config prior to running that script ?

    Regards,
    Swapneel
     
  17. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    RIDICULOUS, HOW COULD THEY NOT TEST THIS.

    COULD THEY NOT GIVE ADVANCE NOTICE THE mbox would be disabled?
     
  18. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    So just all of a sudden they break mbox and everyone still using loses business and customers? Great idea!
     
  19. magixman

    magixman Member

    Joined:
    Sep 28, 2002
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    And where exactly was this notice to be found?

    Is it on the whm news telling people they should upgrade? No.

    Is it in the release notes? No. In fact it says cPanel 11 is the last version to support mbox. It recommends the upgrade but clearly states that 11 will support mbox.

    Look stuff happens. It happens with my software too. You try and support old outdated software that people don't want to upgrade and it becomes difficult to test. You are trying to do people a favor by supporting it but eventaully stuff breaks.

    Credits to cPanel for a very smooth upgrade process. That solved my problem with lost mail and in fact all the missing mail got dropped into the box after the conversion. The missing and grayed hair, however, was not recovered :)

    I really hope that the good folks at cPanel will stick something up on whm news or else fix this as lost email is one's worst nightmare.
     
  20. ClearSky

    ClearSky Well-Known Member

    Joined:
    Jul 9, 2003
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I'm all for moving on from the old, but I'm curious, where was the announcement. I'm not saying there wasn't one, I'm just curious where I should have looked to see this particular one (and future ones).

    Thanks :)
     
Loading...

Share This Page