The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email failure to a specific domain (broken pipe)

Discussion in 'E-mail Discussions' started by elleryjh, Mar 15, 2006.

  1. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    I am getting a broken pipe on connecting to a specific host. The destination host is another server, not running cPanel. I can traceroute to the mail server normally, and perform a simple telnet over port 25 to test the SMTP. Can anyone give some insight to what is going wrong here?

    log entries from /var/log/exim_mainlog:
    Code:
    2006-03-13 06:00:24 1FIkmi-00069r-Aa <= xxxxx@xxxxxxxxxx.se H=me-x-xx-xx-xx-xx-xx.2.cust.bredband2.com ([192.168.0.100]) [83.233.xxx.xxx] P=esmtpa A=fixed_plain:xxxxx S=161283 id=262db8be58e85490deafb4ae9ebde486@xxxxxxxxxx.se
    2006-03-13 06:00:26 1FIkmi-00069r-Aa mail.xxx.se [213.50.xx.xxx]: Broken pipe
    2006-03-13 06:00:28 1FIkmi-00069r-Aa == xxxxx.xxxxx@xxx.se R=lookuphost T=remote_smtp defer (32): Broken pipe: mail.xxx.se [213.50.xx.xxx]
    ...
    2006-03-13 13:08:28 1FIkmi-00069r-Aa mail.xxx.se [213.50.xx.xxx]: Broken pipe
    2006-03-13 13:08:28 1FIkmi-00069r-Aa == xxxxx.xxxxx@xxx.se R=lookuphost T=remote_smtp defer (32): Broken pipe: mail.xxx.se [213.50.xx.xxx]
    ...
    2006-03-13 16:39:57 1FIkmi-00069r-Aa SMTP timeout while connected to mail.xxx.se [213.50.xx.xxx] after sending data block (8189 bytes written): Connection timed out
    2006-03-13 16:39:57 1FIkmi-00069r-Aa == xxxxx.xxxxx@xxx.se R=lookuphost T=remote_smtp defer (110): Connection timed out: SMTP timeout while connected to mail.xxx.se [213.50.xx.xxx] after sending data block (8189 bytes written)
    ...
    2006-03-13 19:21:09 1FIkmi-00069r-Aa mail.xxx.se [213.50.xx.xxx]: Broken pipe
    2006-03-13 19:21:09 1FIkmi-00069r-Aa == xxxxx.xxxxx@xxx.se R=lookuphost T=remote_smtp defer (32): Broken pipe: mail.xxx.se [213.50.xx.xxx]
    ...
    2006-03-13 21:16:50 1FIkmi-00069r-Aa == xxxxx.xxxxx@xxx.se R=lookuphost T=remote_smtp defer (-53): retry time not reached for any host
    ...
    2006-03-14 07:50:06 1FIkmi-00069r-Aa mail.xxx.se [213.50.xx.xxx]: Broken pipe
    2006-03-14 07:50:06 1FIkmi-00069r-Aa == xxxxx.xxxxx@xxx.se R=lookuphost T=remote_smtp defer (32): Broken pipe: mail.xxx.se [213.50.xx.xxx]
    2006-03-14 07:50:06 1FJ8yU-0006W3-4A <= <> R=1FIkmi-00069r-Aa U=mailnull P=local S=1196
    
    Deliver Message:
    Code:
    Message 1FIkmi-00069r-Aa is not frozen
    delivering 1FIkmi-00069r-Aa
    Connecting to mail.xxx.se [213.50.xx.xxx]:25 ... connected
      SMTP<< 220 SMTP service ready
      SMTP>> EHLO server.xxx.net
      SMTP<< 250-Requested mail action okay, completed
             250-SIZE
             250-8bitmime
             250-AUTH LOGIN
             250 AUTH=LOGIN
      SMTP>> MAIL FROM:<xxxxx@xxxxxxxxx.se> SIZE=164480
      SMTP<< 250 Requested mail action okay, completed
      SMTP>> RCPT TO:<xxxxx.xxxxx@xxx.se>
      SMTP<< 250 Requested mail action okay, completed
      SMTP>> DATA
      SMTP<< 354 Start mail input; end with <CRLF>.<CRLF>
      SMTP>> writing message and terminating "."
    LOG: MAIN
      mail.xxx.se [213.50.xx.xxx]: [b]Broken pipe[/b]
    LOG: MAIN
      == xxxxx.xxxxx@xxx.se R=lookuphost T=remote_smtp defer (32): Broken pipe: mail.xxx.se [213.50.xx.xxx]
    
    telnet to mail.xxx.se 25:
    Code:
    telnet mail.xxx.se 25
    Trying 213.50.xx.xxx...
    Connected to mail.xxx.se (213.50.xx.xxx).
    Escape character is '^]'.
    220 SMTP service ready
    EHLO server.xxx.net
    250-Requested mail action okay, completed
    250-SIZE
    250-8bitmime
    250-AUTH LOGIN
    250 AUTH=LOGIN
    MAIL FROM:test@xxx.net
    250 Requested mail action okay, completed
    quit
    
    Thanks for your help.
     
    #1 elleryjh, Mar 15, 2006
    Last edited: Mar 15, 2006
  2. rustelekom

    rustelekom Well-Known Member
    PartnerNOC

    Joined:
    Nov 13, 2003
    Messages:
    290
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    moscow
    it is not your problem. target mail server has a problem. may be just disk space fill out may be something else.
     
Loading...

Share This Page