The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Filter does not work

Discussion in 'E-mail Discussions' started by osnsmita, Feb 15, 2006.

  1. osnsmita

    osnsmita Registered

    Feb 15, 2006
    Likes Received:
    Trophy Points:

    When setting Email Filters using Cpanel >> Mail >> E-mail Filtering option ,
    only the "Contains" option work. Anyother option like "Equals", "begins with"
    does not work. I have set to email filtering rules , first one is :-

    Filter " To " >> that "begins with" >> "test" >>Destination "Discard"
    Rule appear like this way:- $header_to: begins "test".

    This rule is not able to discard mail when I send mail to a test account of my
    client like Below is the mail log:-

    2006-02-02 23:11:18 1EtdWO-0001OI-DQ <=
    H=( [] P=esmtps X=TLSv1:AES256-SHA:256 S=1807
    2006-02-02 23:11:18 1EtdWO-0001OI-DQ => test<>
    R=virtual_sa_user T=virtual_sa_userdelivery
    2006-02-02 23:11:18 1EtdWO-0001OI-DQ Completed

    If I put "contains" it works perfectly, in log you can see mail is getting
    forwarded to /dev/null. Below is Filter rule and mail log:-
    Filter Rule :- $header_to: contains "test"
    2006-02-02 23:34:23 1Etdsj-0006ne-D8 <= U=foxwoods
    P=local-bsmtp S=2201 id=002a01c61020$ef1de6f0$0e05a8c0@testPC
    2006-02-02 23:34:23 1Etdsj-0006ne-D8 => /dev/null <>
    R=central_filter T=**bypassed**
    2006-02-02 23:34:23 1Etdsj-0006ne-D8 Completed

    Has somebody faced such problem on their Cpanel server? Anyone knows solution for this ?

Share This Page