Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Email filter seems to be missing messages

Discussion in 'E-mail Discussion' started by pubwvj, Feb 14, 2005.

  1. pubwvj

    pubwvj Active Member

    Joined:
    Mar 15, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    In the Mountains of Vermont
    I have the email filter and it seems to miss a lot of mail that the test says it should catch.

    Any idea why?

    Filter:
    $h_X-Spam-Status: begins "Yes"+++++++/dev/null
    $header_X-Spam-Level: contains "*****"+++++++/dev/null
    $header_from: contains "automated-response"+++++++/dev/null


    Test results:
    Filter Trace Results:
    The Filter has matched the following condition:
    $h_X-Spam-Status: begins Yes
    Return-path taken from "Return-path:" header line
    Return-path = <>
    Sender = bling@host32.root-name-server.net
    Recipient = bling@host32.root-name-server.net
    Testing Exim filter file "/etc/vfilters/blacklighting.com"
    Save message to: /dev/null 0660
    Filtering set up at least one significant delivery or other action.
    No other deliveries will occur.


    Typical message:
    From: Mailer-Daemon@host32.root-name-server.net
    Subject: [n100.3] Mail delivery failed: returning message to sender
    Date: February 14, 2005 8:49:36 PM EST
    To: bling@host32.root-name-server.net
    Return-Path: <>
    Envelope-To: bling@host32.root-name-server.net
    Delivery-Date: Mon, 14 Feb 2005 19:49:52 -0600
    Received: from bling by host32.root-name-server.net with local-bsmtp (Exim 4.44) id 1D0rqK-00073H-US for bling@host32.root-name-server.net; Mon, 14 Feb 2005 19:49:40 -0600
    Received: from mailnull by host32.root-name-server.net with local (Exim 4.44) id 1D0rqK-00073D-Qg for bling@host32.root-name-server.net; Mon, 14 Feb 2005 19:49:36 -0600
    X-Failed-Recipients: pearce_bh@cibs.de
    Auto-Submitted: auto-generated
    Message-Id: <E1D0rqK-00073D-Qg@host32.root-name-server.net>
    X-Spam-Prev-Subject: Mail delivery failed: returning message to sender
    X-Spam-Flag: YES
    X-Spam-Checker-Version: SpamAssassin 3.0.2 (2004-11-16) on host32.root-name-server.net
    X-Spam-Level: **************************************************
    X-Spam-Status: Yes, score=100.3 required=0.9 tests=AWL,USER_IN_BLACKLIST autolearn=no version=3.0.2
    X-Spam-Report: * 100 USER_IN_BLACKLIST From: address is in the user's black-list * 0.3 AWL AWL: From: address is in the auto white-list
    Sender: <bling@host32.root-name-server.net>
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. kwdavids

    kwdavids Member

    Joined:
    Jan 12, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    151
    Same here...

    I have the same problem. Any email with a blank Return-Path header bypasses all the filters.

    Kevin
     
  3. Wallaby

    Wallaby Well-Known Member

    Joined:
    Aug 15, 2001
    Messages:
    131
    Likes Received:
    1
    Trophy Points:
    318
  4. kwdavids

    kwdavids Member

    Joined:
    Jan 12, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    151
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice