The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Filtering to a script

Discussion in 'E-mail Discussions' started by newhorizonz, Sep 24, 2004.

  1. newhorizonz

    newhorizonz Registered

    Joined:
    Sep 24, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Not sure if this is the right place to post this but here goes:--

    I am developing a script that will be activated automatically each time a new email arrives at a specified email address and process the data using the CPanel Email filtering. I have an address (update@newhorizonz.net) with a filter set to forward thus: |/home/www/cgi-bin/testmail.pl

    I have succeeded in getting the script (Perl) to run when the email arrives and as I track the emails sent from Outlook I get the standard notification to say that the email has arrived:
    -------------------------------------------------------------
    This is an automatically generated Delivery Status Notification.

    Your message has been successfully relayed to the following recipients, but the requested delivery status notifications may not be generated by the destination.

    update@newhorizonz.net
    --------------------------------------------------------------

    Now the problem is that although the script runs and I get emailed back my results I also receive a Mail delivery failed report which says that the script to which I filter the email could not receive the email (although it has because the email ran the script!!):

    ---------------------------------------------------


    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

    pipe to |/home/aisamcg/www/cgi-bin/testmail.pl
    generated by update@newhorizonz.net
    local delivery failed

    ------ This is a copy of the message, including all the headers. ------

    Return-path:
    Received: from [195.188.213.5] (helo=smtp-out2.blueyonder.co.uk)
    by server68.totalchoicehosting.com with esmtp (Exim 4.34)
    id 1CAuzg-0002C2-KA
    for update@newhorizonz.net; Fri, 24 Sep 2004 14:40:32 -0400
    Received: from NHOFFICE ([82.33.73.66]) by smtp-out2.blueyonder.co.uk with Microsoft SMTPSVC(5.0.2195.6713);
    Fri, 24 Sep 2004 19:41:04 +0100
    Return-Receipt-To: "new Horizonz"
    Reply-To:
    From: "new Horizonz"
    To:
    Subject: test
    Date: Fri, 24 Sep 2004 19:40:41 +0100
    Organization: new Horizonz
    Message-ID:
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_NextPart_000_004F_01C4A26E.63196F10"
    X-Priority: 3 (Normal)
    X-MSMail-Priority: Normal
    X-Mailer: Microsoft Outlook, Build 10.0.2616
    Importance: Normal
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
    Disposition-Notification-To: "new Horizonz"
    X-OriginalArrivalTime: 24 Sep 2004 18:41:04.0170 (UTC) FILETIME=[0BCF10A0:01C4A266]

    This is a multi-part message in MIME format.

    ------=_NextPart_000_004F_01C4A26E.63196F10
    Content-Type: text/plain;
    charset="us-ascii"
    Content-Transfer-Encoding: 7bit

    test

    ------=_NextPart_000_004F_01C4A26E.63196F10
    Content-Type: text/html;
    charset="us-ascii"
    Content-Transfer-Encoding: quoted-printable

    test
    ------=_NextPart_000_004F_01C4A26E.63196F10--




    --------------------------------------------

    Can anyone advise how I can overcome this?

    Many thanks

    Alan
     
  2. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
  3. newhorizonz

    newhorizonz Registered

    Joined:
    Sep 24, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Yeah - sort of same thing but using email filtering! Can it be cured?
     
  4. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    You can contribute your findings to that bug report, or maybe open a support ticket with cPanel. I am not sure how far they will support you with your scripting effort, but if you have the same problem with all autoresponders they should help with that.

    Be sure to follow-up :)
     
Loading...

Share This Page