The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Filters Stopped Working... Please Help!!!

Discussion in 'E-mail Discussions' started by nitromax, Jun 26, 2002.

  1. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    For some reason email filters stopped working. I checked the /etc/vfilters file and the filter rule is there for a given user. The owner is set to the user, and the group is set to &mail&.

    Are there perl modules or any other thing that mail filters are dependant on that I might need to reinstall? I just ran the /scripts/easyapache. Any connection there?
     
  2. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Run /scripts/mailperm
    Just to be safe.............

    Then, make sure the .filter placeholder files within the ~username directory in question haven't vanished.
     
  3. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    I ran the /scripts/mailperm script as suggested, and then I checked the .filter file. Everything seems in tact. I tried the same test on one of our own domains. Mail blocking is not working across the board.

    Any other ideas?

    The only thing that has changed recently is that we ran the /scripts/easyapache script to upgrade apache, PHP, and what ever else that upgrades.
     
  4. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    The apache script can't possibly have any affect on this.....

    Did your exim.conf get overwritten or gutted by some other mysterious force?

    Does this entry exist within your /etc/exim.conf ?


    ................................................(cut)

    central_filter:
    driver = forwardfile
    file = /etc/vfilters/${domain}
    no_check_local_user
    no_verify
    filter
    file_transport = address_file
    pipe_transport = virtual_address_pipe

    ...............................................(cut)

    If so, and if permissions are 100% ok, there isn't much else to look at... I can't imagine how the easyapache script has any bearing here, unless somehow your compilers were screwed and and their upgrade/reinstallation affected exim in some way.
     
  5. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    The exim.conf file seems ok. I checked the section you suggested and it is exactly as you showed it in your example.

    I also checked the /etc/vfilter/domain.com file and it shows this:


    ---------------------------------------------
    # Exim filter

    if error_message then finish endif

    if
    $header_to: is &user@domain.com&
    then
    save /dev/null
    endif
    ----------------------------------------------

    I checked the /dev/null file and it looks like this:

    root@saturn [/dev]# ls -la null
    crw-rw-rw- 1 root root 1, 3 Aug 30 2001 null

    ----------------------------------------------

    Should the owner/group on that file be set to root, and are the permissions correct for that file?

    Is there an error file for exim that I could examine to try and trace what's happening?

    Is there a CPanel method for updating/reinstalling exim in such a way that it wouldn't effect any of the users?
     
  6. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    Well, I hate to say this, but here is what I was setting the filter up as, and my client did the same thing...

    $header_to: is (equals) &user@domain.com&

    That doesn't work... But if you do it like this it does:

    $header_to: contains &user@domain.com&


    I'm not sure why the first one wouldn't work. My apologies!!! Thanks Trevor!!! I appreicate it!
     
Loading...

Share This Page