Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Email Forms Problem

Discussion in 'E-mail Discussion' started by cleanmax, Nov 15, 2013.

  1. cleanmax

    cleanmax Registered

    Joined:
    Nov 15, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hello, I am new to the forums, so if this is in the wrong section, sorry for that.

    Well, my problem is to do with emails. I have 2 contact forms on my website, when the form is filled in, and sent, it comes to the email from username @w​n01.domain.pl, thing is, I would like it to come from contact @ otherdomain.co.uk. I have the domain attached, I have created the new email account for contact @ otherdomain.co.uk and I have set it to default, apparently. Is there a way to apply this and so the default email is contact @otherdomain.co.uk? When I as a client, enter my details to the form, press sent, I will receive an email from contact @ otherdomain.co.uk with the form that the client filled in, and the client will receive an email from contact @ otherdomain.co.uk saying that the message has been sent successfuly etc.

    If this is needed, my address of the website: otherdomain.co.uk

    I hope someone understands what my problem is, tried searching for it online but can't find anything.

    Thank You,
    Maciej.
     
    #1 cleanmax, Nov 15, 2013
    Last edited by a moderator: Nov 15, 2013
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,442
    Likes Received:
    1,962
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    The default behavior of Exim is to use the cPanel username and hostname of the server to construct the envelope-sender address. Most applications that call the Exim/Sendmail binary will pass the -f switch along with the proper email address to keep that from happening.

    If you can configure the mailer to use SMTP and authenticate with SMTP AUTH, this will set the correct "Return-Path" in the headers. The other option is to make sure that the application is using the 5th argument to the PHP mail() function to send the '-f' switch to sendmail so that it sets the correct "Return-Path".

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice