The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Forward and Pipe

Discussion in 'E-mail Discussions' started by solarisdev, Apr 7, 2011.

  1. solarisdev

    solarisdev Registered

    Apr 7, 2011
    Likes Received:
    Trophy Points:
    Hi everyone,
    I'm trying to set up email forward with pipe to a program option. When I send message on created email I get
    Mail delivery failed: returning message to sender. What confuses me is that in message i get:
    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    pipe to |/home/lifestyl/public_html/forward.php
    generated by
    local delivery failed

    The following text was generated during the delivery attempt:

    ------ pipe to |/home/lifestyl/public_html/forward.php
    generated by ------

    Status: 404 Not Found
    X-Powered-By: PHP/5.2.14
    Content-type: text/html

    No input file specified.

    ------ This is a copy of the message, including all the headers. ------

    code on PHP file loos like this:
    #!/usr/bin/php –q
    and based on part of that message to me it looks like path is ok... why is this not working?
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Oct 2, 2010
    Likes Received:
    Trophy Points:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Can you try to change this to /usr/local/bin/php instead for the path to see the results? The php.ini file is read from /usr/local/bin/php.ini instead and we actually have two copies of php binary which differ.

Share This Page