The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Forwarding Error

Discussion in 'E-mail Discussions' started by dogzilla, Jun 16, 2005.

  1. dogzilla

    dogzilla Member

    Joined:
    Jan 10, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I recently moved my mail to a different CPanel server, and im getting all sorts of problems.

    I have domain.com and i want to forward 3 addresses 1,2,3@domain.com to hello@different-domain.com. I have setup the forwarders.

    These are the problems im seeing :

    1. It either wont accept my mail because domain.com isnt in localdomains.

    2. It wont forward mail because for some reason there is no domain.com in /etc/valiases

    3. I manually fixed 1,2 however 1,2,3@domain.com are just hitting the catchall and being sent to me@domain.com

    Whats going on?
     
  2. dogzilla

    dogzilla Member

    Joined:
    Jan 10, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I've just re-edited /etc/valiases/domain.com with :


    1@domain.com : hello@different-domain.com

    This now shows up in the email forwarding section of CPANEL.

    HOWEVER! I cannot ADD these from cpanel, i must manually edit the file.

    SECONDLY - not only is mail forwarded, its ALSO getting delivered to the catch all. So im getting double email?
     
    #2 dogzilla, Jun 16, 2005
    Last edited: Jun 16, 2005
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    When you say that you moved it, did you use the cPanel/WHM account transfer procedure? If not, i.e. you simply copied the /home/username/mail directory tree it definitely will not work. One of the first things you should try, if you haven't already is:

    /scripts/updateuserdomains
    /scripts/mailperm
     
  4. dogzilla

    dogzilla Member

    Joined:
    Jan 10, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Basically,

    I moved my website over onto the new cpanel a few months ago.

    My email was still on the old server, yesterday i changed the DNS over and noticed loads of email problems with forwarders.

    This was setting up a normal cpanel account, not transferring the account or anything like that.

    /scripts/mailperm - has just fixed a bunch of stuff but not anything to do with my domain.

    My domain is also removed from /etc/localdomains now, so its not accepting mail.
     
  5. dogzilla

    dogzilla Member

    Joined:
    Jan 10, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Any idea's guys?

    I would have paid someon to sort it by now, but nobody seems to offer freebsd support.
     
  6. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    If you swiched the domain a few months ago but left the Mail on the old server then you must have also removed your domain from /etc/localdomains or none of your local forms would have worked.

    Just add the domain to the /etc/localdomains and check to see if it is in /etc/remotedomains.

    If it is in /etc/remotedomains remove it from there.
     
  7. dogzilla

    dogzilla Member

    Joined:
    Jan 10, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    It keeps getting removed from localdomains for some reason, ive added it like 5 times already!
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you checked that the domain is not listed in /etc/remotedomains? If it has, remove it and then run:

    /scripts/mailperm

    and check that it has been placed back into /etc/localdomains.
     
Loading...

Share This Page