The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Forwarding

Discussion in 'E-mail Discussions' started by inFused, Apr 16, 2004.

  1. inFused

    inFused Registered

    Joined:
    Mar 13, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I've searched through the forums, and found other users experiencing the same issue as I am, however, nothing has solved my problem.

    I've ran /scripts/fixeverything, and /scripts/fixvaliases.

    The error is:
    The forwarder to <edited>@<edited> has been added.

    Fatal! Write Failure: /<edited>. Ignore any messages of success this can only result in failure!

    It appears that cPanel is trying to write to /domainname.tld (and confirmed) instead of /etc/valiases/domainname.tld. I have set the VALIASDIR and VFILTERDIR in /var/cpanel/cpanel.config, however it still does not work.

    Can anyone assist me with this issue?

    Version information:
    WHM 9.2.0 cPanel 9.2.0-C4
    RedHat 9 - WHM X v2.1.2


    Thank you.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I suppose it could be file ownership/permissions. Make sure that:

    /etc/valiases is CHMOD 755 and owned by root:root

    Make sure that all the files within /etc/valiases are:

    Owned by mainuser:mail where mainuser is the main account user, and that the group is mail, files should be CHMOD 644.
     
  3. inFused

    inFused Registered

    Joined:
    Mar 13, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    All of the permissions are correct. (one of the first things I checked)

    Any other options?

    Thank you.
     
  4. rsaylor

    rsaylor Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    160
    Likes Received:
    1
    Trophy Points:
    18
    I had the same problem today and thanks to this thread it led me to the right direction. For those who have this problem this is what I did.

    1. /etc/valiases
    2. ls (the domain.com file)
    3. if it is missing: touch domain.com (where domain is the domain name)
    4. chmod 644 domain.com
    5. chown user.mail domain.com

    Goto cPanel and create your forward. Then cat domain.com to see the contents. If the file has the alias and the forwarding email then it should be ok.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You might also want to run:
    /scripts/mailperm

    Which will also correct file permissions for the /etc/valiases/ files.
     
  6. rsaylor

    rsaylor Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    160
    Likes Received:
    1
    Trophy Points:
    18
    Good point but for small tasks I trust manual over a script :)
     
Loading...

Share This Page