Email from a single domain (university) not being received at VPS/Cpanel

tnedator

Member
Oct 20, 2007
23
0
51
I have a problem where all email sent from uaccb.edu (studentmail.uaccb.edu [208.190.226.130]} is not arriving at my VPS. The people sending email from the above domain are not getting any errors, it is not being marked as spam, it is just being blackholed somehow.

I have checked the above IP and domain, and can't find it on any blacklist, and I am using pretty standard cPanel setup on my VPS. I have spam set to be marked and receive a fair amount and have it autorouted to a folder rather than auto-deleted.

From uaccb.edu, the only thing I have access to is Outlook Web Access to send test emails, and they are sent fine with no errors returned. If I send test emails to gmail and other similar email accounts, they go through fine, the only problem is to ANY domain hosted on my VPS. I have even recently transferred all the domains to a second VPS (with the same hosting company) at a different datacenter (for different reason) and the problem persists.

Is there any WHM setting or any ideas on how to troubleshoot this?

Thanks
 

tnedator

Member
Oct 20, 2007
23
0
51
can you actually reach the sending server from your vps? it looks like a connectivity problem
FWIW, the problem followed me changing VPS (same host) from a Dallas datacenter to a Miami datacenter. This problem has also persisted for at least 3 weeks, but I think longer.

From the VPS (SSH) I can ping the IP address 208.190.226.130, but in the email header that I receive at Gmail, it shows it as studentmail.uaccb.edu ([208.190.226.130]) and if I try and ping studentmail.uaccb.edu I get a Host not found.

The Gmail headers also say that uaccb.edu has an SPF record indicating 208.190.226.130 is a "permitted sender"

So, the best I can figure, there is connectivity between the VPS and uaccb.edu is ok.

There is nothing in the exim_mainlog or exim_rejectlog for uaccb.edu or that IP address.

I'm really stumped here.
 

tnedator

Member
Oct 20, 2007
23
0
51
have you checked your firewalls (if any)

and can you telnet to port 25 on that IP?
There is no entry for 208.190.226.130 in any of the firewall logs.

The domains on this VPS are receiving all other email normally, it is only the email coming from uaccb.edu that never arives.

I am not that familiar with telnet. This is what I tried from my VPS:

Code:
[email protected] [~]# telnet 208.190.226.130 25
Trying 208.190.226.130...
telnet: connect to address 208.190.226.130: Connection refused
Would they likely have port 25 open on their mail server? I thought that was commonly blocked. They are using exchange server (outlook web access) for their students.