Email inboxes disappeared from global webmail login

Freggio

Registered
Sep 7, 2017
3
0
1
London
cPanel Access Level
Root Administrator
Hello!

Have cPanel set up on my main domain with several add on domains within that.

Each add on domain has one or more email accounts.

Yesterday something went wrong with the email server and all the email accounts became inaccessible and all the cPanel email quotas showed 0% even though there are thousands of emails in some of them.

Normally you can access webmail for each email account separately by going to the email accounts page and selecting 'Access Webmail' from the 'more' button beside each email account. You can also see global Webmail for the account by going to yourdomain.com/webmail.

Yesterday when the email problem occured I tried to access the email accounts by logging in to yourdomain.com/webmail and clicking on each account in the left menu. Doing this showed a error message. Something like 'This account cannot be accessed because the inbox does not exist' then the account was removed from the left menu.

Overnight the server issue has resolved itself and the email accounts appear normal within cPanel. All the quotas are now back to the levels they were before the problem.

I'm now able to access each email account individually through webmail. However the accounts are still missing from the global login. So its now impossible to see all the accounts in one place.

As far as I remember if I create a new email account on cPanel its automatically added to the webmail left menu. And I can't see any way to manually add the accounts to webmail.

Does anyone know how I can get the accounts to appear in the global webmail left menu? Thanks.

Please note although I'm using Roundcube this effects all cPanel webmail access (Horde, Squirrelmail) so this is not an email client specific issue.
 

rpvw

Well-Known Member
Jul 18, 2013
1,101
459
113
UK
cPanel Access Level
Root Administrator
In roundcube, click on the 'gear' icon at the bottom of the list of folders in the left menu and select 'manage folders'
Check all the folders you want to be n the left menu
Click on the Mail icon again (top right) and you should now see all the newly selected folders

Hope this helps
 

Freggio

Registered
Sep 7, 2017
3
0
1
London
cPanel Access Level
Root Administrator
In roundcube, click on the 'gear' icon at the bottom of the list of folders in the left menu and select 'manage folders'
Check all the folders you want to be n the left menu
Click on the Mail icon again (top right) and you should now see all the newly selected folders

Hope this helps
Hi rpvw. Thanks for your reply.

Unfortunately the other email accounts are not listed in the 'manage folders' section. They are completely gone.

Screengrab of what I see in 'manage folders' below.

screencapture-oliverfisher-2096-cpsess3893276357-webmail-paper_lantern-index-html-1504788777411.png
 

rpvw

Well-Known Member
Jul 18, 2013
1,101
459
113
UK
cPanel Access Level
Root Administrator
Out of curiosity, have you tried logging into the webmail access for the Default Email Account (right at the bottom of the Email Accounts page) from inside cPanel itself ?
 

Freggio

Registered
Sep 7, 2017
3
0
1
London
cPanel Access Level
Root Administrator
Out of curiosity, have you tried logging into the webmail access for the Default Email Account (right at the bottom of the Email Accounts page) from inside cPanel itself ?
Just tried that. Its the same as the screengrab. Just the main inbox and nothing else. Even in the 'Manage folders'.
 

rpvw

Well-Known Member
Jul 18, 2013
1,101
459
113
UK
cPanel Access Level
Root Administrator
Over to cPanelMichael - this is now above my pay grade o_O
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Yesterday something went wrong with the email server and all the email accounts became inaccessible and all the cPanel email quotas showed 0% even though there are thousands of emails in some of them.
Hello,

This isn't a normal occurrence, so even though quotas and logins are now working, it's possible there's still an unresolved issue on the system. Could you open a support ticket using the link in my signature so we can take a closer look?

Thank you.