The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email interception

Discussion in 'E-mail Discussions' started by Ingens Networks, Oct 1, 2014.

  1. Ingens Networks

    Ingens Networks Registered

    Joined:
    Oct 1, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,

    At the moment, we don't use any CPANEL/WHM Email services (because we have other email server), but when we installed, we selected Exim as mail server. Now we verified that any of our hosted web sites can't send email to outside, because Exim or any other component on the server is intercepting SMTP connections and forcing to connect to localhost. For example.. we configure SMTP server as 213.27.221.213 in a Wordpress web site and when we try to send email we can see in web site logs that is trying to connect to localhost rather than the server specified in the code.. also happens with other type of libraries for example swiftmailer. We read some documentation about configuring Exim to forward all to other mail server, but in our case we would like that every web page will can use any SMTP server, and do not send emails through Exim..

    Do you understand me?

    Thanks!
     
  2. Ingens Networks

    Ingens Networks Registered

    Joined:
    Oct 1, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Also, we have this option for email routing:

    Capture.JPG

    Thanks
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  4. Ingens Networks

    Ingens Networks Registered

    Joined:
    Oct 1, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi!

    The problema was solverd, The solution was to verify that all domains has configured "Remote Mail Exchanger" and verify that the setting in "WHM > Server configuration > Tweak Settings > Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak)" is Off

    Thanks
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page