The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email issue

Discussion in 'E-mail Discussions' started by Meerkat, Aug 23, 2012.

  1. Meerkat

    Meerkat Member

    Dec 1, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator

    I'm having an issue with external emails from my server, the issue arose when a user was trying to verify their account via IP.Board forums. An email is not delivered to them. I've also tried logging in to the webmail at port 2095, and tried sending an email from there to my personal address, but I receive the error:

    There was an error sending your message: Failed to add recipient: ****** [SMTP: Invalid response code received from server (code: 550, response: Authentication failed)]

    That error was received using Horde.

    I've tried sending an email from my personal account to one on the server and it is received fine, so it appears that the issue is for external emails only. As I've also tried sending internally too and it works fine.

    Does anyone have an ideas?

  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Oct 2, 2010
    Likes Received:
    Trophy Points:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Karl,

    Do you have root WHM and root SSH access? If so, is CSF running on the machine? It's been known to cause issues for webmail detailed in this post:

    Next, in root SSH, please check the following:

    Please replace with the domain name in question.

    Sometimes, people add their main domain as both the main domain and the server's hostname and cause email to not function for the account. Sometimes, the domain is missing in /etc/userdomains, /etc/domainusers or /etc/truedomainusers files:

    grep /etc/userdomains /etc/domainusers /etc/truedomainusers
    If the domain is missing from one of these, please move the files to force it to re-add:

    mv /etc/userdomains /etc/userdomains.bak
    mv /etc/domainusers /etc/domainusers.bak
    mv /etc/trueuserdomains /etc/trueuserdomains.bak
    Next, check the routing for one of the email addresses:

    exim -bt
    Please replace with the email address that isn't working for webmail in your tests.

    If you show an error for routing, check /etc/localdomains and /etc/remotedomains files for the domain. It should be in /etc/localdomains file if the domain's MX is pointed to the machine:

    grep /etc/localdomains /etc/remotedomains
    If it is in /etc/remotedomains, remove it from that file, then run /scripts/mailperm to ensure it adds to /etc/localdomains file and check again if it is in either file after you've run the script.


Share This Page