The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email issues when just pointing to www record

Discussion in 'E-mail Discussions' started by bradyb, Jul 20, 2007.

  1. bradyb

    bradyb Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    Wanted to see what you guys and gals may know about an issue I am having.

    Example:

    justatest.com has a www record pointing to their ip on my box. Their DNS is handled elsewhere.

    When i send an email to a user @justatest.com it never goes anywhere. I believe the issue is I am only hosting the website itself and they use exchange server inhouse. I send email from same box, The email gets sent i guess to queue and the user never gets it because my box thinks they are using email on my box..

    Hope that makes any sence. Hope Someone may have some suggestions.
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Log into that account's Cpanel interface, then in the mail section click on the Option to change the MX record. Change the MX record on the local machine so that it references the hostname of the Exchange server where the mail should be sent.

    Mike
     
  3. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    You also need to make sure that the domain is NOT in /etc/localhosts and is IN /etc/remotehosts
     
  4. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator

    That would be - make sure it is NOT in /etc/localdomains and IS IN /etc/remotedomains. But if you go through the Cpanel interface and set the MX correctly, Cpanel will automatically remove the host from localdomains and put it in remotedomains.

    Mike
     
  5. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Doh! Thanks for the correction Mike. You are of course correct. :)
     
Loading...

Share This Page