Email not sending from WHM or websites, using external email host and CloudFlare

Rowan1

Registered
Aug 14, 2014
3
0
1
cPanel Access Level
Root Administrator
Hi I have been experiencing email issues since I swapped to a new host, I am also now using cloud flare for cdn and am not sure if that has contributed to the problem.

The Issue is that WHM doesn't send any emails any more, no alerts from CFS or any other services, as well as my websites hosted on the server, no longer send emails to users or myself.

I am sure it’s down to the configuration and would really appreciate help in configuring it correctly.

I am using a VPS with centos 6.5 and WHM/Cpanel, for the email exchange I am using Microsoft Online, I am also using Cloud Flare as a CDN, and am running Prestashop sites that are currently using PHP mail function.

The name servers on my registrar point to cloud flares name servers, and in cloud flare I have all the MX records set up for Microsoft Online there.

All the email delivery reports say that the "message could not be delivered".
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,880
2,256
463
Hello :)

Do you see the delivery attempts in /var/log/exim_mainlog? If so, what are the specific error messages for those messages?

Thank you.
 

Rowan1

Registered
Aug 14, 2014
3
0
1
cPanel Access Level
Root Administrator
Hi Michael,

Thanks for the response, if you want the full report I can send that to you, as it is to big to post and is mainly a repeat of what is bellow, I have defiantly stuffed something up in the configuration:confused:


- Removed -
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,880
2,256
463
You can just post a single message log snippet of one message ID. You may find the "exigrep" utility helpful. EX:

Code:
exigrep [email protected] /var/log/exim_mainlog
Thank you.
 

Rowan1

Registered
Aug 14, 2014
3
0
1
cPanel Access Level
Root Administrator
Fixed:) silly me the SMTP turned out to be blocked, can't believe I didn't think to check that earlier.

Thank you for the help Michael.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,880
2,256
463
I am happy to see you were able to resolve the issue. Thank you for updating us with the outcome.