The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

email() Not working VIA web form

Discussion in 'E-mail Discussions' started by Lestat, Dec 4, 2007.

  1. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    PHPNuke email activations

    Apparently it has stop working. Seems as if the mail() function has been disabled. I have incorporated a no email activation required but still need the mail() function to work for other clients. I have businesses that require the web mail functions to work. How do I fix this?
     
  2. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    Apparently it has stop working. Seems as if the mail() function has been disabled. I have incorporated a no email activation required but still need the mail() function work for other clients. I have businesses that require the web mail functions to work. How do I fix this?
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    ** Merged Duplicate Threads **
     
  4. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    sorry about that... apparently an update was pushed last night and fowled this up...
     
  5. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    First, ensure you haven't disabled mail() in the disable_functions directive of the php.ini file. You can access the PHP configuration by going to WHM -> Service Configuration -> PHP Configuration Editor. Note, on concurrent PHP setups, this only shows the configuration for PHP 5 at this time (the developers are working on a solution to this issue, no ETA though).

    Next thing you may want to do is check the Exim queue (WHM -> Email -> Mail Queue Manager) to ensure your messages aren't getting stuck in the queue for whatever reason.
     
  6. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    Mail SMTP Used under Windows only: host name or IP address of the SMTP server PHP should use for mail sent with the mail() function. localhost **DEFAULT**, Click to Edit

    Mail sendmail_from me@localhost.com **DEFAULT**, Click to Edit

    Mail sendmail_path /usr/sbin/sendmail -t -i

    Mail smtp_port 25

    how do know if disabled.

    I have an email on server if someone PM's me I get email but if user doesn't get an email notification email. Only sends to local users on the server apparently.
     
  7. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Scroll down to disabled_functions.
     
  8. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    In addition to what cPanelDavidG said, login to the WHM >> Main >> Server Configuration >> Tweak Settings and make sure the option "Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)" is not checked. Also, make sure you didn't enable "SMTP Tweak" in the WHM>> Main >> Security >> Security Center

    See if that helps.
     
  9. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    It is unchecked already...
     
  10. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16

    I am in PHP Configuration Editor advanced. I see nothing resembling disable_functions any where
    I see options like:
    Apache
    BCMath
    Core
    Database Abstraction
    Error Handling and Logging
    Exif
    Filesystem
    Informix
    Java
    mail
    Microsoft SQL
    Multibyte String
    MySQL
    Network
    ODBC
    Options & Information
    Output Control
    PostgreSQL
    Safe Mode
    Session Handling
    Sybase
    Verisign Payflow Pro
    Zlib
    mSQL
     
  11. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    anyone there?
     
  12. kmpanilla

    kmpanilla Member

    Joined:
    Oct 24, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    try compiling php5 as a CGI. that fixed our issue.
     
  13. kmpanilla

    kmpanilla Member

    Joined:
    Oct 24, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Unfortunately php as a CGI causes more issues with users that have "php_value" settings in .htaccess. So this is still a BIG issue with PHP compiled as a DSO / module. Can someone from cpanel confirm?
     
  14. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Although I am not with the the cPanel support, php_value in .htaccess file won't work when SuPhp is enabled. This article will explain, read carefully: http://servertune.com/kbase/entry/184/
     
  15. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    I have tried above how to fix this problem. I have yet to find the disable functions you guys speak of. This is still an issue and I have yet to resolve the matter. Anyone else having issues with this?
     
  16. Lestat

    Lestat Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    199
    Likes Received:
    0
    Trophy Points:
    16
    OK found this is my disable functions
    show_source, system, shell_exec, passthru, exec, phpinfo, popen, proc_open, allow_url_fopen

    was in the editor you spoke of in WHM but under safe_mode
     
    #16 Lestat, Apr 12, 2008
    Last edited: Apr 12, 2008
Loading...

Share This Page