Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Email nur über exim möglich

Discussion in 'Diskussion auf Deutsch' started by grubas, Dec 17, 2018.

  1. grubas

    grubas Registered

    Joined:
    Dec 17, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    litau
    cPanel Access Level:
    Root Administrator
    Hallo,
    ich habe folgendes problem, ich betreibe ein onlineshop, und werde erpresst das ich zahlen soll.
    ich habe bereits eine stark eingestellte CSF firewall, die gute arbeit macht.

    ich habe durch die ddos attaken auch clouldflare im einsatz die meine ip adresse versteckt, jetzt zum entgeltlichen problem.

    mein ip adresse kann ich über cloudflare schützen, aber das problem ist das ich emails über shop verschicke, und dort geht nur die einstellung

    PHP-Funktion mail() verwenden (empfohlen, funktioniert in den meisten Fällen) diese funktioniert

    wenn ich aber meine daten vom email anbiten eintrage unter

    Meine eigenen SMTP-Einstellungen verwenden (NUR für Experten)

    dann bekomme ich immer ein fehler und kann keine mails verschicken, dieser fehler wird mir angezigt

    Fehler: Bitte prüfen Sie Ihre Einstellungen
    Connection could not be established with host mail.runbox.com [ #0]

    ich habe schon einige mail abieten probier es geht in mit keinen.

    das problem ist wenn ich, das hier verwende wird die server domain / ip freigegebn in der mail
    PHP-Funktion mail() verwenden (empfohlen, funktioniert in den meisten Fällen) diese funktioniert

    diese möchte ich schützen, wo liegt mein fehler..??
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @grubas,

    Are you attempting to send email via SMTP authentication through a remote mail server? If so, check to verify that the following option is not enabled:

    WHM >> SMTP Restrictions

    Also, make sure the CSF setting noted on the following thread is not preventing the email delivery:

    SMTP Connection Refused for any Account Except root

    Thank you.

    Translation:

    Hallo @grubas,

    Versuchen Sie, E-Mails über die SMTP-Authentifizierung über einen Remote-Mail-Server zu senden? Wenn ja, überprüfen Sie, ob die folgende Option nicht aktiviert ist:

    WHM >> SMTP Restrictions

    Stellen Sie außerdem sicher, dass die im folgenden Thread angegebene CSF-Einstellung die E-Mail-Zustellung nicht verhindert:

    SMTP Connection Refused for any Account Except root

    Vielen Dank.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. grubas

    grubas Registered

    Joined:
    Dec 17, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    litau
    cPanel Access Level:
    Root Administrator
    I just looked, and it's on display

    WHM >> SMTP Restrictions -> The SMTP restriction is disabled.

    in CSF, SMTP_BLOCK is on.

    but if I deactivate the CSF completely it is still not, as already said it is only this attitude

    PHP function mail () use (recommended, works in most cases) this works

    but my ip is betrayed in every email.

    Do you have another idea..?? is it because of the MX setting or TXT .. ??

    Thank you
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    There's a thread here that looks to match the issue you have described:

    Allow single account PHP direct email relaying

    Let me know if this helps.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. grubas

    grubas Registered

    Joined:
    Dec 17, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    litau
    cPanel Access Level:
    Root Administrator
    thanks you helped me on

    here the cpanel owner must be registered

    Note: root (UID: 0) is always allowed
    SMTP_ALLOWUSER = <---- cpanel user
    SMTP_ALLOWGROUP =

    then you can send email remotely, and my ip address is protected.

    Thank you very much
     
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    47,529
    Likes Received:
    2,181
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello @grubas,

    I'm glad to see you were able to solve the issue. Thank you for sharing the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    grubas likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice