The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

email passwords being written incorrecly?

Discussion in 'E-mail Discussions' started by technicals, Sep 1, 2006.

  1. technicals

    technicals Member

    May 19, 2005
    Likes Received:
    Trophy Points:
    Hi folks,

    This is a really strange problem. On a newly installed server I'm having a very difficult time with setting up pop accounts. Passwords are being rejected. The addresses are able to receive email, but webmail and pop access both fail.

    When I create an account or set the password, the hashes don't seem to match up. I've written a perl script to compare a hash to a plaintext password using perl's crypt() interface (see below), and they're not matching. I find this a bit disturbing, so I've tried an upcp/upcp --force and it didn't help matters any. I even tried /scripts/fixpop to create the account, but with the exact same results.

    Does anyone have an idea about the cause? I mean how can it write the wrong hash? You'd think it would be all or nothing. I haven't tried is cracking the hashes to see whether they're meaningful, but that might take ~forever. Maybe I'm looking at the wrong thing. :rolleyes:

    WHM/Os Information:
    WHM 10.8.0 cPanel 10.8.2-R119
    CentOS 4.3 i686 - WHM X v3.1.0

    print("Encrypted password: "); $enc = <>;
    print("Compare with: "); $pass = <>;

    $test = crypt($pass, $enc);


    print("[$test] vs [$enc]\n");
    if($test eq $enc) {
    } else {

Share This Page