The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Problem! Help

Discussion in 'E-mail Discussions' started by lifehost, Jan 21, 2006.

  1. lifehost

    lifehost Member

    Joined:
    Dec 18, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi, Im having a problem with my Webmail...

    When i login to my email account i get this message when i go onto neomail..

    When i go onto Horde it loads up, i can view the mail, but onto of the page i get...

    and when i go onto Squirrel Mail i get this error, nothing loads up exept for this..

    I would really appreciate it if anyone can help me. Thanks! :confused:
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Looks like PHP is having permission problems trying to access session files in /tmp.

    What permissions do you have on /tmp? Have you changed anything to do with /tmp recently?
     
  3. lifehost

    lifehost Member

    Joined:
    Dec 18, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Not that i no of, i changed the folder to 777 and they worked instantly! Thanks mate for showing me the way! ;)
     
  4. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Dont just change the permission to 777 for /tmp. Add a sticky bit to the directory by changing the permission to 1777.

    EDIT : I was just 2 mins late. I guess "Izzee" and I was replying at the same time. :)
     
    #4 madaboutlinux, Jan 21, 2006
    Last edited: Jan 21, 2006
  5. lifehost

    lifehost Member

    Joined:
    Dec 18, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    it only lets me set 3 digits :S
     
  6. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Execute the command as :-
    chmod 1777 /tmp
    and then check the permission for /tmp. It should be :- drwxrwxrwt
     
  7. brainx

    brainx Member

    Joined:
    Jul 9, 2003
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I was having the same problem and i deleted the horde log file from /tmp .Owner of this file was the root user so after deleting and refreshing horde, the file has been created again.This time the owner changed to cpanel.Its working fine now.
    Thanks
     
  8. webone_helder

    webone_helder Registered

    Joined:
    Sep 28, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    How can I change this permissions ? Where ? :rolleyes:
     
  9. angelina_holy

    angelina_holy Well-Known Member

    Joined:
    Aug 6, 2006
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    run these command at root

    Execute the command as :-
    chmod 1777 /tmp
    and then check the permission for /tmp. It should be :- drwxrwxrwt
     
  10. DCH

    DCH Member

    Joined:
    May 4, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    mmk I did this... but....

    777 lets SQM work.
    1777 does not...

    So... I shouldn't just leave it at 777 right?
     
  11. brendanrtg

    brendanrtg Well-Known Member

    Joined:
    Oct 4, 2006
    Messages:
    311
    Likes Received:
    0
    Trophy Points:
    16
    Instead of setting it to 777, which is DANGEROUS, just delete the log files from /tmp and the system will recreate it again.

     
  12. adel

    adel Member

    Joined:
    Jun 16, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    has this got anything to do with a recent cpanel update?
    i had exacltly same issue
     
Loading...

Share This Page