The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email problem

Discussion in 'E-mail Discussions' started by popeye, Jul 13, 2013.

  1. popeye

    popeye Well-Known Member

    Joined:
    May 23, 2013
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Hi can anyone help i keep getting this message below and customers do when they setup email on computers or phones, i do have ssl installed on the host name so not sure why i get this error ?

    The server you are connected to is using a security certificate that could not be verified. A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider


    The ssl is installed on the host name and works great with whm and cpanel, but when i install the same one on Dovecot Mail Server it says issuer is my host name not rapid ssl ?
     
    #1 popeye, Jul 13, 2013
    Last edited: Jul 13, 2013
  2. robb3369

    robb3369 Well-Known Member

    Joined:
    Mar 1, 2008
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    When you examine your SSL certificate of working cpanel ssl certificate (via Manage Service SSL Certificates), select install new certificate, enter "Domain this CRT" and click fetch...

    Copy each of the fields to text editor:
    1: Certificate (.crt)
    2: Private key (.key)
    3: The CA bundle

    (If you don't have a CA bundle, check your cpanel install via SSL Checker - SSL Certificate Verify (use server.domain.com:2096 as hostname to test and make sure you have no chain errors)

    Now, go back (DO NOT make any changes!!!) and go back into Manage Service SSL Certificates), select install new certificate for the Dovecot Mail Server and paste the 3 items your copied above...

    See if that works for you... Since we use a wildcard SSL, it gets a little more interesting...
     
  3. popeye

    popeye Well-Known Member

    Joined:
    May 23, 2013
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Hi i have an ssl installed on cPanel/WHM/Webmail Service which works fine and says issuer RapidSSL CA but it does not show in Dovecot Mail Server says issuer and got my host name in there ?

    I went to SSL Checker and got all green ticks.

    Tried what you said copied and pasted them all in and still the same?
     
    #3 popeye, Jul 13, 2013
    Last edited: Jul 13, 2013
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are the customers using the hostname of the server for the mail server name in their email client, or are they using their specific domain name?

    Thank you.
     
  5. popeye

    popeye Well-Known Member

    Joined:
    May 23, 2013
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Hi customers are using their own domain like this mail.domain.com
     
  6. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    If they use secure connection they must use the hostname of the server for the mail server name.
     
  7. popeye

    popeye Well-Known Member

    Joined:
    May 23, 2013
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Yes we tried the server name but still get dovecot: (auth failed
     
  8. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    In your 1st post in this thread you told they get a certificate error, an authentication error is totally different thing and has nothing to do with the certificate.
     
  9. popeye

    popeye Well-Known Member

    Joined:
    May 23, 2013
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Hi yes customers get both messages
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You will need to ensure the customers configure their email clients to use the SSL certificate name that is used for the mail server in:

    "WHM Home » Service Configuration » Manage Service SSL Certificates"

    An authentication error is likely not related to any SSL warnings. Have you checked to ensure their email address/password are valid, and work with a Webmail application?

    Thank you.
     
  11. popeye

    popeye Well-Known Member

    Joined:
    May 23, 2013
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Hi i have an ssl installed on the host name but when i try to install it on Dovecot Mail Server it says issuer is my host name not rapid ssl ?
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you paste the exact message that appears?

    Thank you.
     
  13. popeye

    popeye Well-Known Member

    Joined:
    May 23, 2013
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Don't get any error just when i check it says issuer is my host name not rapid ssl and Self Signed yes ?
     
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Are you sure that you installed the correct CRT and CABundle that your SSL issuer provided? Feel free to open a support ticket so we can access your server directly and investigate further:

    Submit A Ticket

    You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  15. popeye

    popeye Well-Known Member

    Joined:
    May 23, 2013
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Yes i am sure because on whm / cpanel it says rapis ssl and and when i go to WHM / cPanel /web mail they are all secure.
     
  16. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you open a support ticket so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page