The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

email problems

Discussion in 'E-mail Discussions' started by acidrain97, Jul 10, 2013.

  1. acidrain97

    acidrain97 Member

    Joined:
    Dec 19, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I updated to the latest version of cpanel and all of the sudden I can not access or send email. Roundcube reports connection to storage server failed, squirrel mail is a blank page and horrde 'Login failed because your username or password was entered incorrectly.' Does anyone know how to fix this. I have forced re-installs on all email clients, forced re-install on cpanel, fixed email permissions. nothing. any ideas?

    thanx
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you only experiencing this problem with Webmail, or does it apply to email clients installed on your desktop as well? Do you notice any specific errors in the "/var/cpanel/roundcube/log/errors" file?

    Use the following commands to check if any partitions are at 100% usage:

    Code:
    df -h
    df -i
    Also, check to make sure IMAP is enabled in "WHM Home » Service Configuration » Service Manager".

    Thank you.
     
  3. acidrain97

    acidrain97 Member

    Joined:
    Dec 19, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    the log says
    10-Jul-2013 21:02:15 +0400]: IMAP Error: Login failed for XXXXXXX from XX.XX.XXX.XXX. Could not connect to localhost:143: php_network_getaddresses: getaddrinfo failed: Name or service not known in /usr/local/cpanel/base/3rdparty/roundcube/program/include/rcube_imap.php on line 191 (GET /cpsess6863819433/3rdparty/roundcube/index.php)

    I do not have any firewalls up. is that message saying i have 143 blocked for some reason?
     
  4. acidrain97

    acidrain97 Member

    Joined:
    Dec 19, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I found the problem

    /ect/hosts had a permission of 600. changed it to 644 works now unless this is a bad idea.
     
    #4 acidrain97, Jul 10, 2013
    Last edited by a moderator: Jul 11, 2013
  5. faisikhan

    faisikhan Well-Known Member

    Joined:
    Dec 12, 2011
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Islamabad, Pakistan
    cPanel Access Level:
    Root Administrator
    Well done! No, I don't think its a bad idea as 644 are the recommended permissions on any file. Glad to hear that it is working now for you :)
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Yes, the default permissions on the /etc/hosts file is 0644 so that is a valid solution.

    Thank you.
     
Loading...

Share This Page