The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email Problems

Discussion in 'E-mail Discussions' started by crag364, Dec 20, 2007.

  1. crag364

    crag364 Registered

    Joined:
    Dec 19, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi all,

    I am running a forum which needs to send emails out. But for some reason it sends them to nobody@123.hostname.net (123.hostname.net being my domain). Does anyone have any ideas how to actually get the email address I have set up working. E.g admin@hostname.net.

    This worked fine on my old server but I have no idea why it is doing it on this new one. I have set up the admin email in cpanel which its sending and receiving fine in squirell mail. (cant get outlook to get it to receive though)

    Regards,

    Craig
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Generally, scripts don't use the administrator email set in the cPanel interface. Traditionally the email where forum reports are sent TO are stored in the forum software itself, usually in a configuration screen.
     
  3. crag364

    crag364 Registered

    Joined:
    Dec 19, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I still have this problem and all emails are going through the nobody@ domain throughout the whole site. I have a shop and a forum.

    I read on a page in whm this: 'nobody receives bounce message from email sent via cgi scripts if you are not using suexec.' Could someone explain what this means and if this could be my problem?

    Thanks
     
  4. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    apache and php running as nobody will typically have a return email address as nobody@servername

    you coudl recompile apache with php as a cgi and the replies would be user@servername and I think if you dig deaper you may find a module in the php config during ea3 run for even more configuring this sort of thing.
     
  5. crag364

    crag364 Registered

    Joined:
    Dec 19, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Well finally got this sorted with help from my server support team. If anyone else has the same problems I thought I would post the solution here:

    Go into WHM and edit these settings:

    1) Server Configuration - Tweak Settings: Checked the check box for "Prevent the user "nobody" from sending out mail to remote addresses (PHP and CGI scripts generally run as nobody if you are not using PHPSuexec and Suexec respectively.)"
    2) Service Configuration -> Exim Configuration Editor: I went into the advanced editor and added the following rewrite rule -- "*@*.yourdomain.com $1@yourdomain.com Ffrs"
     
Loading...

Share This Page