Final-Solution

Well-Known Member
Jul 14, 2002
92
0
156
So, I just use cpanel for my own website, on my server, not to host other people . . and I had my email account working alright for awhile. The other day I stopped getting emails!

My mail queue was filled with undelivered spam as well. I tried searching here for some ways to fix it, but somehow one of the suggestions only made it worse!

The last thing I tried was /scripts/convert2maildir and now ~me/mail/domain/me/inbox is gone! When I log into Horde it just says There are no messages in this mailbox. I work really long hours and have about a half hour free to play with it a night, can anyone make a suggestion? I tried updating everything but it didnt put things back to normal.

Right now where my inbox should be I have ./ ../ courierimapkeywords/ courierimapuiddb cur/ new/ .Sent/ tmp/

Did it change email programs or something?
 

Spiral

BANNED
Jun 24, 2005
2,020
8
193
Maildir doesn't use any "inbox" files and that is the whole point!

Instead all your messages each go into their own files places in a directory
usually something like:

/home/(account login)/mail/(domain)/(email username)/new

for new mail and for read mail ....

/home/(account login)/mail/(domain)/(email username)/cur

When you converted the mbox format to maildir, you split up the mail
that was in the inbox files and parsed those into their own messages
located into folders per above.

Webmail programs might need to be reconfigured a bit possibly
to read the new mailboxes particularily if you moved mail out
of your inbox but it should be no big deal.
 

Final-Solution

Well-Known Member
Jul 14, 2002
92
0
156
Ok . . so now the message go into different folders. But now I have no messages in my inbox, at least before (when I wasn't getting any new mail) I still had my old mail. And still nothing new is being delivered :/ wierd.

I just did
/scripts/courierup --force
/scripts/eximup --force

courierup worked fine the second time I ran it, but eximup gave me this at the end:

exim has failed, please contact the sysadmin.
Install Complete


When I try to restart exim from whm i get this at the end:
Oct 11 19:03:59 server1 exim: spamd startup succeeded Oct 11 19:04:08 server1 exim: exim shutdown failed Oct 11 19:04:12 server1 exim: antirelayd shutdown succeeded Oct 11 19:04:14 server1 exim: spamd shutdown succeeded exim has failed, please contact the sysadmin.

And since I don't get any mail I figured I'd try to send one from the queue and got:
Message 1GX5y9-00025W-IX is not frozen
delivering 1GX5y9-00025W-IX
LOG: MAIN
== [email protected] R=temp_defer defer (-1): Mail Server Upgrade in Progress. Message Queued.


The service status in whm says exim is up . .
cpsrvd up
exim (exim-4.52-15_cpanel_maildir) up
exim-26 up
eximstats up
imap up


I'll try emailup again, courierup worked the second time . . maybe it will too??
 
Last edited:

Final-Solution

Well-Known Member
Jul 14, 2002
92
0
156
No such luck . . still said it failed running eximup, but it still says exim is running on Service Status. Wrote to cpanel, maybe they'll have an idea? I gotta have the email :P