The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

email queue problem

Discussion in 'E-mail Discussions' started by nsgit, Nov 6, 2006.

  1. nsgit

    nsgit Registered

    Joined:
    Oct 27, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am a new user. We just set up our server. I see that many times outbound emails just sit in the que for very long. 15 to 1 hour and more. If I go to the panel and force it to deliver an individual email, it does quickly.

    What could be the reasons and how it can be avoided? The problem does not happen to call the emails.
     
  2. bhd

    bhd Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    149
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    JNB ZA
    cPanel Access Level:
    Root Administrator
    Exim has many setting that govern mail delivery. It could be any one of these:

    In WHM, first, take a look at Server Configuration -> Tweak Settings -> Number of minutes between mail server queue runs, and make sure it is not set to some ridiculously high value.

    Then, in exim.conf (or the advanced config editor in WHM), check for things like queue_only_load, timeout_frozen_after, ignore_bounce_errors_after, and make sure they are set to reasonable sounding values if they exist. There are many more things your config file may have but these are the ones I've found can seriously mess with mail delivery. If you don't know what an option does, you can check on the exim website.
     
Loading...

Share This Page