The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email routing problem

Discussion in 'E-mail Discussions' started by Yossi, Oct 6, 2015.

  1. Yossi

    Yossi Member

    Joined:
    Sep 12, 2015
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Israel
    cPanel Access Level:
    Root Administrator
    Hey,

    I am hosting my Email server on a different MX server, as defined in the DNS records.
    My hostname is c1.

    When I send mail from the server, to the same domain (account owner) using the mail() function, it doesn't work.

    If the mail is sent to an outside source (such as Gmail), it would work perfectly. Since it's the same domain, it has a routing problem.

    How could I fix this?

    Code:
    [B]Event[/B]: failure
    [B]Sender User[/B]: tiy
    [B]Sender Domain[/B]: example.com
    [B]Sender[/B]: tiy@c1
    [B]Sent Time[/B]: Oct 6, 2015 2:23:14 PM
    [B]Sender Host[/B]: localhost
    [B]Sender IP[/B]: 127.0.0.1
    [B]Authentication[/B]: localuser
    [B]Spam Score[/B]: 0
    [B]Recipient[/B]: [EMAIL]info@example.com[/EMAIL]
    [B]Delivered To[/B]:
    [B]deliveryuser[/B]: tiyooli
    [B]deliverydomain[/B]: example.com
    [B]Router[/B]: fail_remote_domains
    [B]Transport[/B]: remote_smtp
    [B]Out Time[/B]: Oct 6, 2015 2:23:14 PM
    [B]ID[/B]: 1ZjQKn-0002E9-Do
    [B]Delivery Host[/B]:
    [B]Delivery IP[/B]:
    [B]Size[/B]: 1.17 KB
    [B]Result[/B]: The mail server could not deliver mail to tiy@c1. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
    
    
    Thanks a lot!
     
    #1 Yossi, Oct 6, 2015
    Last edited by a moderator: Oct 6, 2015
  2. Yossi

    Yossi Member

    Joined:
    Sep 12, 2015
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Israel
    cPanel Access Level:
    Root Administrator
    I think it was solved with setting the setting of the domain in the "Edit MX" to "Remote Server" instead of auto-detect..
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I am happy to see you were able to resolve the issue. Thank you for updating us with the outcome.
     
Loading...

Share This Page